aboutsummaryrefslogtreecommitdiff
path: root/net/gnomemeeting
diff options
context:
space:
mode:
Diffstat (limited to 'net/gnomemeeting')
-rw-r--r--net/gnomemeeting/Makefile70
-rw-r--r--net/gnomemeeting/distinfo3
-rw-r--r--net/gnomemeeting/files/patch-configure70
-rw-r--r--net/gnomemeeting/files/patch-endpoint24
-rw-r--r--net/gnomemeeting/files/patch-lib_gtk-text-buffer-addon.h11
-rw-r--r--net/gnomemeeting/files/patch-lib_gtk-text-tag-addon.c10
-rw-r--r--net/gnomemeeting/files/patch-lib_xdap_xdap.c11
-rw-r--r--net/gnomemeeting/files/patch-src_config.cpp15
-rw-r--r--net/gnomemeeting/files/patch-src_druid.cpp26
-rw-r--r--net/gnomemeeting/files/patch-src_gnomemeeting.cpp28
-rw-r--r--net/gnomemeeting/files/patch-src_sound_handling.cpp71
-rw-r--r--net/gnomemeeting/files/patch-src_vfakeio.cpp265
-rw-r--r--net/gnomemeeting/files/patch-src_vfakeio.h39
-rw-r--r--net/gnomemeeting/pkg-descr9
-rw-r--r--net/gnomemeeting/pkg-plist113
15 files changed, 0 insertions, 765 deletions
diff --git a/net/gnomemeeting/Makefile b/net/gnomemeeting/Makefile
deleted file mode 100644
index c7f73b2028b6..000000000000
--- a/net/gnomemeeting/Makefile
+++ /dev/null
@@ -1,70 +0,0 @@
-# Ports collection Makefile for: gnomemeeting
-# Date created: 24/07/2001
-# Whom: roger@FreeBSD.org
-#
-# $FreeBSD$
-#
-
-PORTNAME= gnomemeeting
-PORTVERSION= 1.2.1
-PORTREVISION= 1
-CATEGORIES= net gnome
-MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:R}
-
-MAINTAINER= netchild@FreeBSD.org
-COMMENT= GNOME H323 Video Conferencing program, similar to NetMeeting
-
-LIB_DEPENDS= h323_r:${PORTSDIR}/net/openh323 \
- howl:${PORTSDIR}/net/howl
-
-DEPRECATED= Superseeded by net/ekiga
-EXPIRATION_DATE=2006-06-01
-BROKEN= conflict between howl for gnomemeeting and avahi for GNOME 2.14
-
-USE_BZIP2= yes
-USE_X_PREFIX= yes
-USE_GETTEXT= yes
-USE_GMAKE= yes
-USE_GNOME= libgnomeui libbonobo gnomeprefix gnomehack evolutiondataserver \
- intlhack
-INSTALLS_OMF= yes
-USE_OPENLDAP= yes
-GCONF_SCHEMAS= gnomemeeting.schemas
-USE_SDL= yes
-USE_BISON= yes
-# Clear configure target so we stop getting binaries prefixed with i386-portbld-freebsd46
-CONFIGURE_TARGET=
-USE_AUTOTOOLS= libtool:15
-CONFIGURE_ENV= OSTYPE=${OPSYS} \
- CXXFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${PREFIX}/lib -L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
- SDL_CONFIG=${LOCALBASE}/bin/sdl11-config \
- CPPFLAGS="-I${LOCALBASE}/include ${LDAP_CPPFLAGS} ${PTHREAD_CFLAGS}" \
- PTLIBDIR=${PREFIX}
-
-CONFIGURE_ARGS= --with-pwlib-dir=${LOCALBASE} \
- --with-openh323-dir=${LOCALBASE} \
- --with-ldap-dir=${LOCALBASE}
-
-MAN1= gnomemeeting.1
-
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == sparc64 && ${OSVERSION} <= 700003
-BROKEN= configure fails due to missing symbol in default thread library
-.endif
-
-.if (${WANT_OPENLDAP_VER} == "23")
-LDAP_CPPFLAGS= -DLDAP_DEPRECATED
-.endif
-
-post-patch:
- ${REINPLACE_CMD} -e 's:-lh323_FreeBSD_x86_r_s:-lh323_r:g; \
- s:-lpt_FreeBSD_x86_r_s:-lpt_r:g; \
- s:-lh323_FreeBSD_x86_r:-lh323_r:g; \
- s:-lpt_FreeBSD_x86_r:-lpt_r:g; \
- s: -DSTATIC_LIBS_USED::g' \
- ${WRKSRC}/configure
-
-.include <bsd.port.post.mk>
diff --git a/net/gnomemeeting/distinfo b/net/gnomemeeting/distinfo
deleted file mode 100644
index c50040547f4d..000000000000
--- a/net/gnomemeeting/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (gnomemeeting-1.2.1.tar.bz2) = e765914ed1eb547d4a15d211e2ae9f57
-SHA256 (gnomemeeting-1.2.1.tar.bz2) = c33c8363c8c6d37e8792f8e716def593d9d8ceeb420f9bd6583ebe2b4297beec
-SIZE (gnomemeeting-1.2.1.tar.bz2) = 3730480
diff --git a/net/gnomemeeting/files/patch-configure b/net/gnomemeeting/files/patch-configure
deleted file mode 100644
index 0662924203af..000000000000
--- a/net/gnomemeeting/files/patch-configure
+++ /dev/null
@@ -1,70 +0,0 @@
---- configure.orig Thu Mar 16 13:29:08 2006
-+++ configure Thu Mar 16 13:30:44 2006
-@@ -19165,10 +19165,10 @@
-
-
- # This can be used to rebuild libtool when needed
--LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+LIBTOOL_DEPS=" /usr/local/share/libtool/ltmain.sh"
-
- # Always use our own libtool.
--LIBTOOL='$(SHELL) $(top_builddir)/libtool'
-+LIBTOOL='$(SHELL) /usr/local/bin/libtool'
-
- # Prevent multiple expansion
-
-@@ -21283,8 +21283,8 @@
- GNOMEMEETING_LIBS="$GNOMEMEETING_LIBS $EDS_LIBS"
- fi
-
--PWLIB_REC_VERSION="1.8.4"
--OPENH323_REC_VERSION="1.15.3"
-+PWLIB_REC_VERSION="1.10.0"
-+OPENH323_REC_VERSION="1.18.0"
-
-
- if test x"${disable_gnome}" = xno ; then
-@@ -21353,7 +21353,7 @@
-
- FreeBSD* | freebsd* )
- ARCH_OPENH323_CFLAGS="-Os -Wall -DPTRACING -DNDEBUG -DSTATIC_LIBS_USED"
-- ARCH_OPENH323_LIBS="-lh323_FreeBSD_x86_r_s -lpt_FreeBSD_x86_r_s -pthread -lssl -lcrypto"
-+ ARCH_OPENH323_LIBS="-lh323_FreeBSD_x86_r -lpt_FreeBSD_x86_r -pthread -lssl -lcrypto"
- echo "$as_me:$LINENO: result: yes" >&5
- echo "${ECHO_T}yes" >&6
- gm_platform="freebsd"
-@@ -21900,20 +21900,20 @@
- { (exit 1); exit 1; }; };
- fi
-
--echo "$as_me:$LINENO: checking for Quicknet support in OpenH323" >&5
--echo $ECHO_N "checking for Quicknet support in OpenH323... $ECHO_C" >&6;
--OPENH323_IXJ_SUPPORT=`cat ${with_openh323_dir}/include/openh323/openh323buildopts.h | grep "HAS_IXJ 1" | cut -f2 -d ' '`
--if test "x${OPENH323_IXJ_SUPPORT}" != "x1"; then
-- echo "$as_me:$LINENO: result: no" >&5
--echo "${ECHO_T}no" >&6;
-- { { echo "$as_me:$LINENO: error: Sorry but the OpenH323 version you are using doesn't support Quicknet devices" >&5
--echo "$as_me: error: Sorry but the OpenH323 version you are using doesn't support Quicknet devices" >&2;}
-- { (exit 1); exit 1; }; };
--else
-- echo "$as_me:$LINENO: result: yes" >&5
--echo "${ECHO_T}yes" >&6;
-- HAS_IXJ="enabled";
--fi
-+#echo "$as_me:$LINENO: checking for Quicknet support in OpenH323" >&5
-+#echo $ECHO_N "checking for Quicknet support in OpenH323... $ECHO_C" >&6;
-+#OPENH323_IXJ_SUPPORT=`cat ${with_openh323_dir}/include/openh323/openh323buildopts.h | grep "HAS_IXJ 1" | cut -f2 -d ' '`
-+#if test "x${OPENH323_IXJ_SUPPORT}" != "x1"; then
-+# echo "$as_me:$LINENO: result: no" >&5
-+#echo "${ECHO_T}no" >&6;
-+# { { echo "$as_me:$LINENO: error: Sorry but the OpenH323 version you are using doesn't support Quicknet devices" >&5
-+#echo "$as_me: error: Sorry but the OpenH323 version you are using doesn't support Quicknet devices" >&2;}
-+# { (exit 1); exit 1; }; };
-+#else
-+# echo "$as_me:$LINENO: result: yes" >&5
-+#echo "${ECHO_T}yes" >&6;
-+# HAS_IXJ="enabled";
-+#fi
-
-
-
diff --git a/net/gnomemeeting/files/patch-endpoint b/net/gnomemeeting/files/patch-endpoint
deleted file mode 100644
index f0aeb3c62898..000000000000
--- a/net/gnomemeeting/files/patch-endpoint
+++ /dev/null
@@ -1,24 +0,0 @@
---- src/endpoint.cpp.orig Thu Nov 25 20:12:40 2004
-+++ src/endpoint.cpp Mon Dec 13 21:33:19 2004
-@@ -59,6 +59,8 @@
- #include "gm_conf.h"
- #include "gm_events.h"
-
-+#include <libintl.h>
-+
- #include <h261codec.h>
-
- #include <ptclib/http.h>
-@@ -89,8 +91,10 @@
-
- /* Use IPv6 address family by default if available. */
- #ifdef P_HAS_IPV6
-- if (PIPSocket::IsIpAddressFamilyV6Supported())
-- PIPSocket::SetDefaultIpAddressFamilyV6();
-+// ENABLING THIS CAUSES PWLIB TO GIVE AN ASSERTION WHEN THERE IS AN
-+// INCOMING CALL
-+// if (PIPSocket::IsIpAddressFamilyV6Supported())
-+// PIPSocket::SetDefaultIpAddressFamilyV6();
- #endif
-
- audio_tester = NULL;
diff --git a/net/gnomemeeting/files/patch-lib_gtk-text-buffer-addon.h b/net/gnomemeeting/files/patch-lib_gtk-text-buffer-addon.h
deleted file mode 100644
index 5d0cc22ca252..000000000000
--- a/net/gnomemeeting/files/patch-lib_gtk-text-buffer-addon.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/gtk-text-buffer-addon.h.orig Sun Mar 13 15:13:36 2005
-+++ lib/gtk-text-buffer-addon.h Sun Mar 13 15:14:07 2005
-@@ -40,7 +40,7 @@
-
- #include <gtk/gtk.h>
- #include <string.h>
--
-+#include <unistd.h>
-
- #ifndef __GTK_TEXT_BUF_ADD_H
- #define __GTK_TEXT_BUF_ADD_H
diff --git a/net/gnomemeeting/files/patch-lib_gtk-text-tag-addon.c b/net/gnomemeeting/files/patch-lib_gtk-text-tag-addon.c
deleted file mode 100644
index 39588407e283..000000000000
--- a/net/gnomemeeting/files/patch-lib_gtk-text-tag-addon.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- lib/gtk-text-tag-addon.c.orig Sun Mar 13 15:10:05 2005
-+++ lib/gtk-text-tag-addon.c Sun Mar 13 15:10:40 2005
-@@ -37,6 +37,7 @@
- *
- */
-
-+#include <unistd.h>
- #include "gtk-text-tag-addon.h"
-
- /*
diff --git a/net/gnomemeeting/files/patch-lib_xdap_xdap.c b/net/gnomemeeting/files/patch-lib_xdap_xdap.c
deleted file mode 100644
index 6ee81f64df0d..000000000000
--- a/net/gnomemeeting/files/patch-lib_xdap_xdap.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/xdap/xdap.c.orig Tue Oct 28 21:28:24 2003
-+++ lib/xdap/xdap.c Tue Oct 28 21:49:59 2003
-@@ -159,7 +159,7 @@
- xmlSAXHandler sax;
-
- memset (&sax, 0, sizeof sax);
-- sax = xmlDefaultSAXHandler; /* Copy original handler */
-+ xmlSAX2InitDefaultSAXHandler (&sax, 0);
- *oldgetent = sax.getEntity; /* Substitute entity handling */
- if (noerr) {
- sax.error = NULL; /* Disable errors and warnings */
diff --git a/net/gnomemeeting/files/patch-src_config.cpp b/net/gnomemeeting/files/patch-src_config.cpp
deleted file mode 100644
index dfd6acbfd49d..000000000000
--- a/net/gnomemeeting/files/patch-src_config.cpp
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/config.cpp.orig Sun Jan 30 12:27:01 2005
-+++ src/config.cpp Sun Jan 30 12:29:38 2005
-@@ -826,10 +826,12 @@
- && !strcmp (gm_conf_entry_get_key (entry),
- AUDIO_DEVICES_KEY "input_device")) {
-
-+#ifdef HAS_IXJ
- if (dev.Find ("/dev/phone") != P_MAX_INDEX)
- ep->CreateLid (dev);
- else
- ep->RemoveLid ();
-+#endif
-
- capa = ep->GetAvailableAudioCapabilities ();
-
diff --git a/net/gnomemeeting/files/patch-src_druid.cpp b/net/gnomemeeting/files/patch-src_druid.cpp
deleted file mode 100644
index a99103b62826..000000000000
--- a/net/gnomemeeting/files/patch-src_druid.cpp
+++ /dev/null
@@ -1,26 +0,0 @@
---- src/druid.cpp.orig Sun Mar 13 15:15:47 2005
-+++ src/druid.cpp Sun Mar 13 15:17:05 2005
-@@ -1682,9 +1682,11 @@
- * not for a random one.
- */
- gnomemeeting_sound_daemons_suspend ();
-+#ifdef HAS_IXJ
- if (PString ("Quicknet") == audio_manager)
- devices = OpalIxJDevice::GetDeviceNames ();
- else
-+#endif
- devices = PSoundChannel::GetDeviceNames (audio_manager,
- PSoundChannel::Player);
- if (devices.GetSize () == 0) {
-@@ -1699,9 +1701,11 @@
- gm_dw_option_menu_update (dw->audio_player, array, player);
- free (array);
-
-+#ifdef HAS_IXJ
- if (PString ("Quicknet") == audio_manager)
- devices = OpalIxJDevice::GetDeviceNames ();
- else
-+#endif
- devices = PSoundChannel::GetDeviceNames (audio_manager,
- PSoundChannel::Recorder);
- if (devices.GetSize () == 0) {
diff --git a/net/gnomemeeting/files/patch-src_gnomemeeting.cpp b/net/gnomemeeting/files/patch-src_gnomemeeting.cpp
deleted file mode 100644
index cb8a15bfd775..000000000000
--- a/net/gnomemeeting/files/patch-src_gnomemeeting.cpp
+++ /dev/null
@@ -1,28 +0,0 @@
---- src/gnomemeeting.cpp.orig Sun Mar 13 15:18:01 2005
-+++ src/gnomemeeting.cpp Sun Mar 13 15:19:00 2005
-@@ -256,20 +256,22 @@
-
- /* Detect the devices */
- video_input_devices = PVideoInputDevice::GetDriversDeviceNames (video_plugin);
--
-+
-+#ifdef HAS_IXJ
- if (PString ("Quicknet") == audio_plugin) {
-
- audio_input_devices = OpalIxJDevice::GetDeviceNames ();
- audio_output_devices = audio_input_devices;
- }
- else {
--
-+#endif
- audio_input_devices =
- PSoundChannel::GetDeviceNames (audio_plugin, PSoundChannel::Recorder);
- audio_output_devices =
- PSoundChannel::GetDeviceNames (audio_plugin, PSoundChannel::Player);
-+#ifdef HAS_IXJ
- }
--
-+#endif
-
- if (audio_input_devices.GetSize () == 0)
- audio_input_devices += PString (_("No device found"));
diff --git a/net/gnomemeeting/files/patch-src_sound_handling.cpp b/net/gnomemeeting/files/patch-src_sound_handling.cpp
deleted file mode 100644
index 554e3f3a9a4f..000000000000
--- a/net/gnomemeeting/files/patch-src_sound_handling.cpp
+++ /dev/null
@@ -1,71 +0,0 @@
---- src/sound_handling.cpp.orig Sun Mar 6 14:11:32 2005
-+++ src/sound_handling.cpp Fri Mar 17 20:27:11 2006
-@@ -278,8 +278,8 @@
- test anyway */
- static GMLid *l = NULL;
- static PMutex lid_mutex;
-- PINDEX i;
- #endif
-+ PINDEX i;
-
- GMH323EndPoint *ep = NULL;
-
-@@ -335,9 +335,12 @@
- gdk_threads_leave ();
- g_free (msg);
-
-+#ifdef HAS_IXJ
- if ((driver_name != "Quicknet" && !channel)
- || (driver_name == "Quicknet" && (!l || !l->IsOpen ()))) {
--
-+#else
-+ if (driver_name != "Quicknet" && !channel) {
-+#endif
- gdk_threads_enter ();
- if (is_encoding)
- gnomemeeting_error_dialog (GTK_WINDOW (druid_window), _("Failed to open the device"), _("Impossible to open the selected audio device (%s) for recording. Please check your audio setup, the permissions and that the device is not busy."), (const char *) device_name);
-@@ -374,11 +377,16 @@
-
- if (is_encoding) {
-
-+#ifdef HAS_IXJ
- if ((driver_name != "Quicknet"
- && !channel->Read ((void *) buffer, 640))
- || (driver_name == "Quicknet"
- && l
- && !l->ReadFrame (0, (void *) buffer, i))) {
-+#else
-+ if ((driver_name != "Quicknet"
-+ && !channel->Read ((void *) buffer, 640))) {
-+#endif
-
- gdk_threads_enter ();
- gnomemeeting_error_dialog (GTK_WINDOW (druid_window), _("Cannot use the audio device"), _("The selected audio device (%s) was successfully opened but it is impossible to read data from this device. Please check your audio setup."), (const char*) device_name);
-@@ -450,11 +458,17 @@
-
- buffer_pos += 640;
-
-+#ifdef HAS_IXJ
- if ((driver_name != "Quicknet"
- && !channel->Write ((void *) buffer, 640))
- || (driver_name == "Quicknet"
- && l
- && !l->WriteFrame (0, (const void *) buffer, 640, i))) {
-+#else
-+ if ((driver_name != "Quicknet"
-+ && !channel->Write ((void *) buffer, 640))) {
-+
-+#endif
-
- gdk_threads_enter ();
- gnomemeeting_error_dialog (GTK_WINDOW (druid_window), _("Cannot use the audio device"), _("The selected audio device (%s) was successfully opened but it is impossible to write data to this device. Please check your audio setup."), (const char*) device_name);
-@@ -486,7 +500,9 @@
- nbr_opened_channels = PMAX (nbr_opened_channels--, 0);
-
- free (buffer);
-+#ifdef HAS_IXJ
- l = NULL;
-+#endif
- }
-
-
diff --git a/net/gnomemeeting/files/patch-src_vfakeio.cpp b/net/gnomemeeting/files/patch-src_vfakeio.cpp
deleted file mode 100644
index 297aa1e310ba..000000000000
--- a/net/gnomemeeting/files/patch-src_vfakeio.cpp
+++ /dev/null
@@ -1,265 +0,0 @@
---- src/vfakeio.cpp.orig Wed Apr 5 19:20:41 2006
-+++ src/vfakeio.cpp Wed Apr 5 19:20:56 2006
-@@ -51,10 +51,10 @@
- #ifndef DISABLE_GNOME
- #include <libgnomevfs/gnome-vfs.h>
-
--const size_t GMH323FakeVideoInputDevice::buffer_size = 4096;
-+const size_t PVideoInputDevice_Picture::buffer_size = 4096;
- #endif
-
--GMH323FakeVideoInputDevice::GMH323FakeVideoInputDevice ()
-+PVideoInputDevice_Picture::PVideoInputDevice_Picture ()
- {
- orig_pix = NULL;
- cached_pix = NULL;
-@@ -73,7 +73,7 @@
- }
-
-
--GMH323FakeVideoInputDevice::~GMH323FakeVideoInputDevice ()
-+PVideoInputDevice_Picture::~PVideoInputDevice_Picture ()
- {
- Close ();
-
-@@ -83,12 +83,12 @@
- }
-
- #ifndef DISABLE_GNOME
--void GMH323FakeVideoInputDevice::loader_area_updated_cb (GdkPixbufLoader *loader,
-+void PVideoInputDevice_Picture::loader_area_updated_cb (GdkPixbufLoader *loader,
- gint x, gint y, gint width,
- gint height,
- gpointer thisclass)
- {
-- GMH323FakeVideoInputDevice *thisc = static_cast<GMH323FakeVideoInputDevice *> (thisclass);
-+ PVideoInputDevice_Picture *thisc = static_cast<PVideoInputDevice_Picture *> (thisclass);
-
- PWaitAndSignal m(thisc->pixbuf_mutex);
-
-@@ -103,11 +103,11 @@
- g_object_ref (G_OBJECT (thisc->orig_pix));
- }
-
--void GMH323FakeVideoInputDevice::async_close_cb (GnomeVFSAsyncHandle *fp,
-+void PVideoInputDevice_Picture::async_close_cb (GnomeVFSAsyncHandle *fp,
- GnomeVFSResult result,
- gpointer thisclass)
- {
-- GMH323FakeVideoInputDevice *thisc = static_cast<GMH323FakeVideoInputDevice *> (thisclass);
-+ PVideoInputDevice_Picture *thisc = static_cast<PVideoInputDevice_Picture *> (thisclass);
-
- PWaitAndSignal m(thisc->pixbuf_mutex);
-
-@@ -118,14 +118,14 @@
- }
- }
-
--void GMH323FakeVideoInputDevice::async_read_cb (GnomeVFSAsyncHandle *fp,
-+void PVideoInputDevice_Picture::async_read_cb (GnomeVFSAsyncHandle *fp,
- GnomeVFSResult result,
- gpointer buffer,
- GnomeVFSFileSize requested,
- GnomeVFSFileSize bytes_read,
- gpointer thisclass)
- {
-- GMH323FakeVideoInputDevice *thisc = static_cast<GMH323FakeVideoInputDevice *> (thisclass);
-+ PVideoInputDevice_Picture *thisc = static_cast<PVideoInputDevice_Picture *> (thisclass);
-
- if (result != GNOME_VFS_OK && result != GNOME_VFS_ERROR_EOF) {
- gnome_vfs_async_close (fp, async_close_cb, thisclass);
-@@ -144,11 +144,11 @@
- }
- }
-
--void GMH323FakeVideoInputDevice::async_open_cb (GnomeVFSAsyncHandle *fp,
-+void PVideoInputDevice_Picture::async_open_cb (GnomeVFSAsyncHandle *fp,
- GnomeVFSResult result,
- gpointer thisclass)
- {
-- GMH323FakeVideoInputDevice *thisc = static_cast<GMH323FakeVideoInputDevice *> (thisclass);
-+ PVideoInputDevice_Picture *thisc = static_cast<PVideoInputDevice_Picture *> (thisclass);
-
-
- if (result != GNOME_VFS_OK) {
-@@ -160,7 +160,7 @@
- async_read_cb, thisclass);
- }
-
--gboolean GMH323FakeVideoInputDevice::async_cancel (gpointer data)
-+gboolean PVideoInputDevice_Picture::async_cancel (gpointer data)
- {
- gnome_vfs_async_cancel ((GnomeVFSAsyncHandle *)data);
-
-@@ -169,7 +169,7 @@
- #endif
-
- BOOL
--GMH323FakeVideoInputDevice::Open (const PString &name,
-+PVideoInputDevice_Picture::Open (const PString &name,
- BOOL start_immediate)
- {
- gchar *image_name = NULL;
-@@ -222,7 +222,7 @@
-
-
- BOOL
--GMH323FakeVideoInputDevice::IsOpen ()
-+PVideoInputDevice_Picture::IsOpen ()
- {
- if (orig_pix)
- return TRUE;
-@@ -232,7 +232,7 @@
-
-
- BOOL
--GMH323FakeVideoInputDevice::Close ()
-+PVideoInputDevice_Picture::Close ()
- {
- gnomemeeting_threads_enter ();
- #ifndef DISABLE_GNOME
-@@ -264,28 +264,28 @@
-
-
- BOOL
--GMH323FakeVideoInputDevice::Start ()
-+PVideoInputDevice_Picture::Start ()
- {
- return TRUE;
- }
-
-
- BOOL
--GMH323FakeVideoInputDevice::Stop ()
-+PVideoInputDevice_Picture::Stop ()
- {
- return TRUE;
- }
-
-
- BOOL
--GMH323FakeVideoInputDevice::IsCapturing ()
-+PVideoInputDevice_Picture::IsCapturing ()
- {
- return IsCapturing ();
- }
-
-
- PStringList
--GMH323FakeVideoInputDevice::GetInputDeviceNames ()
-+PVideoInputDevice_Picture::GetInputDeviceNames ()
- {
- PStringList l;
-
-@@ -297,7 +297,7 @@
-
-
- BOOL
--GMH323FakeVideoInputDevice::SetFrameSize (unsigned int width,
-+PVideoInputDevice_Picture::SetFrameSize (unsigned int width,
- unsigned int height)
- {
- if (!PVideoDevice::SetFrameSize (width, height))
-@@ -308,7 +308,7 @@
-
-
- BOOL
--GMH323FakeVideoInputDevice::GetFrame (PBYTEArray &a)
-+PVideoInputDevice_Picture::GetFrame (PBYTEArray &a)
- {
- PINDEX returned;
-
-@@ -322,7 +322,7 @@
-
-
- BOOL
--GMH323FakeVideoInputDevice::GetFrameData (BYTE *a, PINDEX *i)
-+PVideoInputDevice_Picture::GetFrameData (BYTE *a, PINDEX *i)
- {
- WaitFinishPreviousFrame ();
-
-@@ -334,7 +334,7 @@
- }
-
-
--BOOL GMH323FakeVideoInputDevice::GetFrameDataNoDelay (BYTE *frame, PINDEX *i)
-+BOOL PVideoInputDevice_Picture::GetFrameDataNoDelay (BYTE *frame, PINDEX *i)
- {
- guchar *data = NULL;
-
-@@ -418,21 +418,21 @@
-
-
- BOOL
--GMH323FakeVideoInputDevice::TestAllFormats ()
-+PVideoInputDevice_Picture::TestAllFormats ()
- {
- return TRUE;
- }
-
-
- PINDEX
--GMH323FakeVideoInputDevice::GetMaxFrameBytes ()
-+PVideoInputDevice_Picture::GetMaxFrameBytes ()
- {
- return CalculateFrameBytes (frameWidth, frameHeight, colourFormat);
- }
-
-
- void
--GMH323FakeVideoInputDevice::WaitFinishPreviousFrame ()
-+PVideoInputDevice_Picture::WaitFinishPreviousFrame ()
- {
- frameTimeError += msBetweenFrames;
-
-@@ -454,28 +454,28 @@
-
-
- BOOL
--GMH323FakeVideoInputDevice::SetVideoFormat (VideoFormat newFormat)
-+PVideoInputDevice_Picture::SetVideoFormat (VideoFormat newFormat)
- {
- return PVideoDevice::SetVideoFormat (newFormat);
- }
-
-
- int
--GMH323FakeVideoInputDevice::GetNumChannels()
-+PVideoInputDevice_Picture::GetNumChannels()
- {
- return 1;
- }
-
-
- BOOL
--GMH323FakeVideoInputDevice::SetChannel (int newChannel)
-+PVideoInputDevice_Picture::SetChannel (int newChannel)
- {
- return PVideoDevice::SetChannel (newChannel);
- }
-
-
- BOOL
--GMH323FakeVideoInputDevice::SetColourFormat (const PString &newFormat)
-+PVideoInputDevice_Picture::SetColourFormat (const PString &newFormat)
- {
- if (newFormat == "BGR32")
- return PVideoDevice::SetColourFormat (newFormat);
-@@ -485,7 +485,7 @@
-
-
- BOOL
--GMH323FakeVideoInputDevice::SetFrameRate (unsigned rate)
-+PVideoInputDevice_Picture::SetFrameRate (unsigned rate)
- {
- PVideoDevice::SetFrameRate (12);
-
-@@ -494,7 +494,7 @@
-
-
- BOOL
--GMH323FakeVideoInputDevice::GetFrameSizeLimits (unsigned & minWidth,
-+PVideoInputDevice_Picture::GetFrameSizeLimits (unsigned & minWidth,
- unsigned & minHeight,
- unsigned & maxWidth,
- unsigned & maxHeight)
diff --git a/net/gnomemeeting/files/patch-src_vfakeio.h b/net/gnomemeeting/files/patch-src_vfakeio.h
deleted file mode 100644
index 6427c458371f..000000000000
--- a/net/gnomemeeting/files/patch-src_vfakeio.h
+++ /dev/null
@@ -1,39 +0,0 @@
---- src/vfakeio.h.orig Wed Apr 5 19:20:50 2006
-+++ src/vfakeio.h Wed Apr 5 19:22:28 2006
-@@ -48,9 +48,9 @@
- #include <libgnomevfs/gnome-vfs.h>
- #endif
-
--class GMH323FakeVideoInputDevice : public PVideoInputDevice
-+class PVideoInputDevice_Picture : public PVideoInputDevice
- {
-- PCLASSINFO(GMH323FakeVideoInputDevice, PVideoInputDevice);
-+ PCLASSINFO(PVideoInputDevice_Picture, PVideoInputDevice);
-
- PMutex pixbuf_mutex; /* To protect the pixbufs that are read and written
- from various threads */
-@@ -112,14 +112,14 @@
- * BEHAVIOR : Creates the Fake Input Device.
- * PRE : /
- */
-- GMH323FakeVideoInputDevice ();
-+ PVideoInputDevice_Picture();
-
-
- /* DESCRIPTION : The destructor
- * BEHAVIOR : /
- * PRE : /
- */
-- ~GMH323FakeVideoInputDevice ();
-+ ~PVideoInputDevice_Picture();
-
-
- BOOL Open (const PString &,
-@@ -245,6 +245,6 @@
- { return GetInputDeviceNames(); }
- };
-
--PCREATE_VIDINPUT_PLUGIN (Picture, GMH323FakeVideoInputDevice);
-+PCREATE_VIDINPUT_PLUGIN (Picture);
-
- #endif
diff --git a/net/gnomemeeting/pkg-descr b/net/gnomemeeting/pkg-descr
deleted file mode 100644
index 9a8d6e495a8d..000000000000
--- a/net/gnomemeeting/pkg-descr
+++ /dev/null
@@ -1,9 +0,0 @@
-Gnomemeeting is a Video Conferencing application which uses the H323
-protocol and the OpenH323 libraries.
-
-It can connect to a variety of other H323 applications including
-Microsoft NetMeeting, OpenMCU, OpenAM, OhPhone and CPhone.
-
-WWW: http://www.gnomemeeting.org/
-
-Roger Hardiman <roger@freebsd.org>
diff --git a/net/gnomemeeting/pkg-plist b/net/gnomemeeting/pkg-plist
deleted file mode 100644
index 64717a91125a..000000000000
--- a/net/gnomemeeting/pkg-plist
+++ /dev/null
@@ -1,113 +0,0 @@
-bin/gnomemeeting
-bin/gnomemeeting-config-tool
-libdata/bonobo/servers/gnomemeeting.server
-share/gnome/applications/gnomemeeting.desktop
-share/gnome/gnomemeeting/xdap/ils_nm_mod.xml
-share/gnome/gnomemeeting/xdap/ils_nm_reg.xml
-share/gnome/gnomemeeting/xdap/ils_nm_unreg.xml
-share/gnome/help/gnomemeeting/C/figures/audio_codecs.png
-share/gnome/help/gnomemeeting/C/figures/call_d1.png
-share/gnome/help/gnomemeeting/C/figures/config_d1.png
-share/gnome/help/gnomemeeting/C/figures/config_d10.png
-share/gnome/help/gnomemeeting/C/figures/config_d2.png
-share/gnome/help/gnomemeeting/C/figures/config_d3.png
-share/gnome/help/gnomemeeting/C/figures/config_d4.png
-share/gnome/help/gnomemeeting/C/figures/config_d5.png
-share/gnome/help/gnomemeeting/C/figures/config_d6.png
-share/gnome/help/gnomemeeting/C/figures/config_d7.png
-share/gnome/help/gnomemeeting/C/figures/config_d8.png
-share/gnome/help/gnomemeeting/C/figures/config_d9.png
-share/gnome/help/gnomemeeting/C/figures/lumi.png
-share/gnome/help/gnomemeeting/C/figures/stats.png
-share/gnome/help/gnomemeeting/C/gnomemeeting.xml
-share/gnome/help/gnomemeeting/fr/figures/audio_codecs.png
-share/gnome/help/gnomemeeting/fr/figures/call_d1.png
-share/gnome/help/gnomemeeting/fr/figures/config_d1.png
-share/gnome/help/gnomemeeting/fr/figures/config_d10.png
-share/gnome/help/gnomemeeting/fr/figures/config_d2.png
-share/gnome/help/gnomemeeting/fr/figures/config_d3.png
-share/gnome/help/gnomemeeting/fr/figures/config_d4.png
-share/gnome/help/gnomemeeting/fr/figures/config_d5.png
-share/gnome/help/gnomemeeting/fr/figures/config_d6.png
-share/gnome/help/gnomemeeting/fr/figures/config_d7.png
-share/gnome/help/gnomemeeting/fr/figures/config_d8.png
-share/gnome/help/gnomemeeting/fr/figures/config_d9.png
-share/gnome/help/gnomemeeting/fr/figures/lumi.png
-share/gnome/help/gnomemeeting/fr/figures/stats.png
-share/gnome/help/gnomemeeting/fr/gnomemeeting.xml
-share/gnome/omf/gnomemeeting/gnomemeeting-C.omf
-share/gnome/omf/gnomemeeting/gnomemeeting-fr.omf
-share/gnome/pixmaps/gnomemeeting-logo-icon.png
-share/gnome/pixmaps/gnomemeeting-logo.png
-share/gnome/pixmaps/gnomemeeting-splash.png
-share/gnome/sounds/gnomemeeting/busytone.wav
-share/gnome/sounds/gnomemeeting/gnomemeeting.wav
-share/gnome/sounds/gnomemeeting/ringtone.wav
-share/locale/am/LC_MESSAGES/gnomemeeting.mo
-share/locale/ar/LC_MESSAGES/gnomemeeting.mo
-share/locale/az/LC_MESSAGES/gnomemeeting.mo
-share/locale/be/LC_MESSAGES/gnomemeeting.mo
-share/locale/bg/LC_MESSAGES/gnomemeeting.mo
-share/locale/bn/LC_MESSAGES/gnomemeeting.mo
-share/locale/bs/LC_MESSAGES/gnomemeeting.mo
-share/locale/ca/LC_MESSAGES/gnomemeeting.mo
-share/locale/cs/LC_MESSAGES/gnomemeeting.mo
-share/locale/cy/LC_MESSAGES/gnomemeeting.mo
-share/locale/da/LC_MESSAGES/gnomemeeting.mo
-share/locale/de/LC_MESSAGES/gnomemeeting.mo
-share/locale/el/LC_MESSAGES/gnomemeeting.mo
-share/locale/en_CA/LC_MESSAGES/gnomemeeting.mo
-share/locale/en_GB/LC_MESSAGES/gnomemeeting.mo
-share/locale/es/LC_MESSAGES/gnomemeeting.mo
-share/locale/eu/LC_MESSAGES/gnomemeeting.mo
-share/locale/fi/LC_MESSAGES/gnomemeeting.mo
-share/locale/fr/LC_MESSAGES/gnomemeeting.mo
-share/locale/ga/LC_MESSAGES/gnomemeeting.mo
-share/locale/gl/LC_MESSAGES/gnomemeeting.mo
-share/locale/gu/LC_MESSAGES/gnomemeeting.mo
-share/locale/hi/LC_MESSAGES/gnomemeeting.mo
-share/locale/hr/LC_MESSAGES/gnomemeeting.mo
-share/locale/hu/LC_MESSAGES/gnomemeeting.mo
-share/locale/id/LC_MESSAGES/gnomemeeting.mo
-share/locale/is/LC_MESSAGES/gnomemeeting.mo
-share/locale/it/LC_MESSAGES/gnomemeeting.mo
-share/locale/ja/LC_MESSAGES/gnomemeeting.mo
-share/locale/ko/LC_MESSAGES/gnomemeeting.mo
-share/locale/lt/LC_MESSAGES/gnomemeeting.mo
-share/locale/lv/LC_MESSAGES/gnomemeeting.mo
-share/locale/mk/LC_MESSAGES/gnomemeeting.mo
-share/locale/ml/LC_MESSAGES/gnomemeeting.mo
-share/locale/mn/LC_MESSAGES/gnomemeeting.mo
-share/locale/mr/LC_MESSAGES/gnomemeeting.mo
-share/locale/ms/LC_MESSAGES/gnomemeeting.mo
-share/locale/nb/LC_MESSAGES/gnomemeeting.mo
-share/locale/ne/LC_MESSAGES/gnomemeeting.mo
-share/locale/nl/LC_MESSAGES/gnomemeeting.mo
-share/locale/no/LC_MESSAGES/gnomemeeting.mo
-share/locale/pa/LC_MESSAGES/gnomemeeting.mo
-share/locale/pl/LC_MESSAGES/gnomemeeting.mo
-share/locale/pt/LC_MESSAGES/gnomemeeting.mo
-share/locale/pt_BR/LC_MESSAGES/gnomemeeting.mo
-share/locale/ro/LC_MESSAGES/gnomemeeting.mo
-share/locale/ru/LC_MESSAGES/gnomemeeting.mo
-share/locale/sk/LC_MESSAGES/gnomemeeting.mo
-share/locale/sq/LC_MESSAGES/gnomemeeting.mo
-share/locale/sr/LC_MESSAGES/gnomemeeting.mo
-share/locale/sr@Latn/LC_MESSAGES/gnomemeeting.mo
-share/locale/sv/LC_MESSAGES/gnomemeeting.mo
-share/locale/ta/LC_MESSAGES/gnomemeeting.mo
-share/locale/tr/LC_MESSAGES/gnomemeeting.mo
-share/locale/uk/LC_MESSAGES/gnomemeeting.mo
-share/locale/vi/LC_MESSAGES/gnomemeeting.mo
-share/locale/wa/LC_MESSAGES/gnomemeeting.mo
-share/locale/zh_CN/LC_MESSAGES/gnomemeeting.mo
-share/locale/zh_TW/LC_MESSAGES/gnomemeeting.mo
-@dirrm share/gnome/help/gnomemeeting/C/figures
-@dirrm share/gnome/help/gnomemeeting/C
-@dirrm share/gnome/help/gnomemeeting/fr/figures
-@dirrm share/gnome/help/gnomemeeting/fr
-@dirrm share/gnome/help/gnomemeeting
-@dirrm share/gnome/omf/gnomemeeting
-@dirrm share/gnome/sounds/gnomemeeting
-@dirrm share/gnome/gnomemeeting/xdap
-@dirrm share/gnome/gnomemeeting