aboutsummaryrefslogtreecommitdiff
path: root/net/gnu-radius/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/gnu-radius/Makefile')
-rw-r--r--net/gnu-radius/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/net/gnu-radius/Makefile b/net/gnu-radius/Makefile
index 3f1395e9e371..cb733a63c247 100644
--- a/net/gnu-radius/Makefile
+++ b/net/gnu-radius/Makefile
@@ -16,9 +16,6 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libltdl.so:devel/libltdl
-CONFLICTS= freeradius-0.* openradius-0.* radiusd-cistron-1.*
-GNU_CONFIGURE= yes
-INSTALL_TARGET= install-strip
USES= cpe gmake libtool
USE_RC_SUBR= radiusd
USE_SUBMAKE= yes
@@ -26,6 +23,10 @@ USE_LDCONFIG= yes
CPE_PRODUCT= radius
CPE_VENDOR= gnu
+CONFLICTS= freeradius-0.* openradius-0.* radiusd-cistron-1.*
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+
PLIST_SUB= PORTVERSION=${PORTVERSION}
DATADIR= ${PREFIX}/share/radius
@@ -52,8 +53,9 @@ MYSQL_CONFIGURE_WITH= mysql
PGSQL_USES= pgsql
PGSQL_CONFIGURE_WITH= postgres
DBM_CONFIGURE_ENABLE= dbm=ndbm
-EMACS_USE= emacs=yes
+EMACS_USES= emacs
EMACS_CONFIGURE_WITH= lispdir=${PREFIX}/${EMACS_SITE_LISPDIR}
+EMACS_NO_DEPENDS= yes
NLS_USES= gettext
NLS_CONFIGURE_OFF= --disable-nls
PAM_CONFIGURE_ENABLE= pam