aboutsummaryrefslogtreecommitdiff
path: root/net/gnugadu/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/gnugadu/Makefile')
-rw-r--r--net/gnugadu/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/net/gnugadu/Makefile b/net/gnugadu/Makefile
new file mode 100644
index 000000000000..199d054d9a3d
--- /dev/null
+++ b/net/gnugadu/Makefile
@@ -0,0 +1,40 @@
+# Ports collection makefile for: gnugadu
+# Date created: 23 dec 2001
+# Whom: doc@lublin.t1.pl
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnugadu
+PORTVERSION= 0.2.0
+CATEGORIES= net
+MASTER_SITES= ftp://ftp.slackware.pl/gg/
+DISTNAME= gg-${PORTVERSION}
+
+MAINTAINER= doc@lublin.t1.pl
+
+WRKSRC= ${WRKDIR}/gg-${PORTVERSION}
+
+USE_GMAKE= yes
+USE_GTK= yes
+WANT_ESOUND= yes
+GNU_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+.if defined(HAVE_ESOUND)
+USE_ESOUND= yes
+.else
+CONFIGURE_ARGS+= --disable-esd
+.endif
+
+post-patch:
+ @${PERL} -pi -e 's,CFLAGS =, CFLAGS += \@GTK_CFLAGS\@,; \
+ s,GTK_ CFLAGS,GTK_CFLAGS,' ${WRKSRC}/Makefile.in \
+ ${WRKSRC}/src/Makefile.in
+ @${PERL} -pi -e 's,-O2,,; s,gtk-config,${GTK_CONFIG},' \
+ ${WRKSRC}/configure
+
+post-install:
+ strip ${PREFIX}/bin/gg
+
+.include <bsd.port.post.mk>