aboutsummaryrefslogtreecommitdiff
path: root/net/gnugadu/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/gnugadu/Makefile')
-rw-r--r--net/gnugadu/Makefile16
1 files changed, 15 insertions, 1 deletions
diff --git a/net/gnugadu/Makefile b/net/gnugadu/Makefile
index deeeba08fcda..f1f1120b4ab7 100644
--- a/net/gnugadu/Makefile
+++ b/net/gnugadu/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gnugadu
-PORTVERSION= 0.2.0
+PORTVERSION= 0.2.2
CATEGORIES= net
MASTER_SITES= ftp://ftp.slackware.pl/gg/
DISTNAME= gg-${PORTVERSION}
@@ -29,6 +29,20 @@ PKGNAMESUFFIX= -esound
CONFIGURE_ARGS+= --disable-esd
.endif
+pre-everything::
+.if defined(WITH_GNOME)
+CONFIGURE_ARGS+= --enable-gnome
+USE_GNOME= yes
+.else
+ @${ECHO_MSG} "Define WITH_GNOME to include GNOME support"
+.endif
+
+.if defined(WITH_DOCKAPP)
+CONFIGURE_ARGS+= --enable-dockapp
+.else
+ @${ECHO_MSG} "Define WITH_DOCKAPP to include WindowMaker support"
+.endif
+
post-patch:
@${PERL} -pi -e 's,CFLAGS =, CFLAGS += \@GTK_CFLAGS\@,; \
s,GTK_ CFLAGS,GTK_CFLAGS,' ${WRKSRC}/Makefile.in \