aboutsummaryrefslogtreecommitdiff
path: root/net/gq/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/gq/Makefile')
-rw-r--r--net/gq/Makefile20
1 files changed, 6 insertions, 14 deletions
diff --git a/net/gq/Makefile b/net/gq/Makefile
index 9c3a3e1bf085..8075664b332a 100644
--- a/net/gq/Makefile
+++ b/net/gq/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gq
PORTVERSION= 1.3.4
-PORTREVISION= 8
+PORTREVISION= 9
PORTEPOCH= 1
CATEGORIES= net
MASTER_SITES= SF/${PORTNAME}client/GQ%20Unstable/${PORTVERSION}
@@ -11,7 +11,7 @@ MASTER_SITES= SF/${PORTNAME}client/GQ%20Unstable/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= GTK-based LDAP client
-LIB_DEPENDS= gnome-keyring:${PORTSDIR}/security/gnome-keyring
+LIB_DEPENDS= libgnome-keyring.so:${PORTSDIR}/security/gnome-keyring
OPTIONS_DEFINE= DND CACHE
OPTIONS_DEFAULT= DND CACHE
@@ -21,24 +21,16 @@ CACHE_DESC= Support the OpenLDAP experimental client cache
USE_GNOME= libglade2 gnomedocutils
USE_OPENSSL= yes
USE_OPENLDAP= yes
-USES= gettext gmake pkgconfig
+USES= gettext gmake pkgconfig shared-mime-info desktop-file-utils
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-ldap-prefix=${LOCALBASE}
+DND_CONFIGURE_ENABLE= browser-dns
+CACHE_CONFIGURE_ENABLE= cache
+INSTALLS_ICONS= yes
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS} -Wno-return-type
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MDND}
-CONFIGURE_ARGS+= --enable-browser-dnd
-.endif
-
-.if ${PORT_OPTIONS:MCACHE}
-CONFIGURE_ARGS+= --enable-cache
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|glib/.*\.h>|glib.h>|g' \
${WRKSRC}/src/syntax.h \