aboutsummaryrefslogtreecommitdiff
path: root/net/gtk+licq/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/gtk+licq/Makefile')
-rw-r--r--net/gtk+licq/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/net/gtk+licq/Makefile b/net/gtk+licq/Makefile
index 068bb00ef1b1..2e4ed207c712 100644
--- a/net/gtk+licq/Makefile
+++ b/net/gtk+licq/Makefile
@@ -21,7 +21,8 @@ RUN_DEPENDS= licq:${PORTSDIR}/net/licq
# It breaks the build for some reason
#USE_LIBTOOL= yes
USE_GMAKE= yes
-USE_GTK= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12
WANT_GNOME= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
@@ -29,8 +30,9 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
.include <bsd.port.pre.mk>
-.if defined(HAVE_GNOME)
-USE_GNOME= yes
+.if ${HAVE_GNOME:Mlibcapplet}!=""
+USE_GNOME+= libcapplet
+PKGNAMESUFFIX= -gnome
CONFIGURE_ARGS+= --enable-gnome
.else
CONFIGURE_ARGS+= --disable-gnome