aboutsummaryrefslogtreecommitdiff
path: root/net/haproxy-devel
diff options
context:
space:
mode:
Diffstat (limited to 'net/haproxy-devel')
-rw-r--r--net/haproxy-devel/Makefile63
-rw-r--r--net/haproxy-devel/distinfo3
-rw-r--r--net/haproxy-devel/files/haproxy.sh.in50
-rw-r--r--net/haproxy-devel/files/patch-Makefile.bsd74
-rw-r--r--net/haproxy-devel/pkg-descr8
-rw-r--r--net/haproxy-devel/pkg-message3
-rw-r--r--net/haproxy-devel/pkg-plist7
7 files changed, 0 insertions, 208 deletions
diff --git a/net/haproxy-devel/Makefile b/net/haproxy-devel/Makefile
deleted file mode 100644
index 113004520a49..000000000000
--- a/net/haproxy-devel/Makefile
+++ /dev/null
@@ -1,63 +0,0 @@
-# New ports collection Makefile for: haproxy
-# Date created: Apr 30, 2003
-# Whom: Clement Laforet
-#
-# $FreeBSD$
-#
-
-PORTNAME= haproxy
-PORTVERSION= 1.2.16
-PORTREVISION= 1
-CATEGORIES= net www
-MASTER_SITES= http://haproxy.1wt.eu/download/1.2/src/
-
-MAINTAINER= clement@FreeBSD.org
-COMMENT= High-performance and highly-robust TCP/HTTP load balancer
-
-USE_RC_SUBR= haproxy.sh
-
-STATS_INTERVAL?= 0
-CFLAGS+= -DSTATTIME=${STATS_INTERVAL}
-
-.if defined(WITH_TPROXY)
-CFLAGS+= -DTPROXY
-.endif
-
-.if defined(WITH_PCRE)
-PKGNAMESUFFIX= -pcre
-LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
-MAKE_ENV+= "REGEX=pcre"
-CFLAGS+= -DUSE_PCRE -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -lpcreposix -lpcre
-.endif
-
-.if defined(WITH_SMALLOPTS)
-CFLAGS+= -DBUFSIZE=8030 -DMAXREWRITE=1030 -DSYSTEM_MAXCONN=1024
-.endif
-
-MAKEFILE= Makefile.bsd
-
-pre-everything::
- @${ECHO_MSG} ""
- @${ECHO_MSG} "Available options:"
- @${ECHO_MSG} "WITH_PCRE: Use pcre regex engine"
- @${ECHO_MSG} "WITH_TPROXY: Enable Transparent proxy support"
- @${ECHO_MSG} "WITH_SMALLOPTS: Enable low memory footprint support"
- @${ECHO_MSG} "STATS_INTERVAL=###: Statistics interval in milliseconds,"
- @${ECHO_MSG} " (default to 0, disabled)"
- @${ECHO_MSG} ""
-
-do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/haproxy ${PREFIX}/sbin
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- @${MKDIR} ${EXAMPLESDIR}
- @${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/examples/haproxy.cfg \
- ${EXAMPLESDIR}/haproxy.cfg
-.endif
-
-post-install:
- @${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.mk>
diff --git a/net/haproxy-devel/distinfo b/net/haproxy-devel/distinfo
deleted file mode 100644
index 1a06fc6b8296..000000000000
--- a/net/haproxy-devel/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (haproxy-1.2.16.tar.gz) = f72c44bcddf868edf4000503be09a12d
-SHA256 (haproxy-1.2.16.tar.gz) = c8635aaf761f3bb74676d6cbc1ebb415cdcebebcdb46261a737a7d69c4251f2f
-SIZE (haproxy-1.2.16.tar.gz) = 197867
diff --git a/net/haproxy-devel/files/haproxy.sh.in b/net/haproxy-devel/files/haproxy.sh.in
deleted file mode 100644
index 9083c615dd65..000000000000
--- a/net/haproxy-devel/files/haproxy.sh.in
+++ /dev/null
@@ -1,50 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD: /tmp/pcvs/ports/net/haproxy-devel/files/Attic/haproxy.sh.in,v 1.1 2006-11-01 14:42:14 clement Exp $
-#
-
-# PROVIDE: haproxy
-# REQUIRE: NETWORKING SERVERS
-# BEFORE: DAEMON
-# KEYWORD: shutdown
-
-#
-# Add the following lines to /etc/rc.conf to enable haproxy:
-# haproxy_enable (bool): Set to "NO" by default.
-# Set it to "YES" to enable haproxy
-# haproxylimits_enable (bool):Set to "NO" by default.
-# Set it to yes to run `limits $limits_args`
-# just before haproxy starts.
-# haproxy_flags (str): Set to "" by default.
-# Extra flags passed to start command
-# haproxylimits_args (str): Default to "-e -C daemon"
-# Arguments of pre-start limits run.
-#
-. %%RC_SUBR%%
-
-name="haproxy"
-rcvar=`set_rcvar`
-
-command="%%PREFIX%%/sbin/haproxy"
-pidfile="/var/run/haproxy.pid"
-required_files=%%PREFIX%%/etc/haproxy.conf
-
-[ -z "$haproxy_enable" ] && haproxy_enable="NO"
-[ -z "$haproxy_flags" ] && haproxy_flags="-p ${pidfile} -f /usr/local/etc/haproxy.conf"
-[ -z "$haproxylimits_enable" ] && haproxylimits_enable="NO"
-[ -z "$haproxylimits_args" ] && haproxylimits_args="-e -C daemon"
-
-load_rc_config $name
-
-checkyesno haproxylimits_enable && \
- start_precmd="eval `/usr/bin/limits ${haproxylimits_args}` 2>/dev/null"
-
-sig_gracefulstop=SIGUSR1
-
-haproxy_gracefulstop() {
- echo "Gracefully shutdown haproxy ($rc_pid)"
- kill -${sig_gracefulstop} ${rc_pid}
- }
-
-extra_commands="gracefulstop"
-run_rc_command "$1"
diff --git a/net/haproxy-devel/files/patch-Makefile.bsd b/net/haproxy-devel/files/patch-Makefile.bsd
deleted file mode 100644
index 4f27d99fbe7e..000000000000
--- a/net/haproxy-devel/files/patch-Makefile.bsd
+++ /dev/null
@@ -1,74 +0,0 @@
---- Makefile.bsd.orig Sun May 21 21:32:29 2006
-+++ Makefile.bsd Sun Sep 24 10:06:30 2006
-@@ -5,22 +5,22 @@
- TARGET = openbsd
-
- # pass CPU=<cpu_name> to make to optimize for a particular CPU
--CPU = generic
-+#CPU = generic
- #CPU = i586
- #CPU = i686
- #CPU = ultrasparc
-
- # By default, we use libc's regex. WARNING! On Solaris 8/Sparc, group
- # references seem broken using libc ! Use pcre instead.
--REGEX=libc
-+REGEX?=libc
- #REGEX=pcre
- #REGEX=static-pcre
-
- # tools options
--CC = gcc
--LD = gcc
-+CC?= gcc
-+LD?= gcc
-
--PCREDIR=/usr/local
-+PCREDIR=${LOCALBASE}
-
- # This is for OpenBSD 3.0
- COPTS.openbsd = -DENABLE_POLL
-@@ -46,7 +46,7 @@
-
- # you can enable debug arguments with "DEBUG=-g" or disable them with "DEBUG="
- #DEBUG = -g -DDEBUG_MEMORY -DDEBUG_FULL
--DEBUG = -g
-+#DEBUG = -g
-
- # if small memory footprint is required, you can reduce the buffer size. There
- # are 2 buffers per concurrent session, so 16 kB buffers will eat 32 MB memory
-@@ -54,7 +54,7 @@
- # will avoid the additionnal paramters to overflow a page. 8030 bytes is
- # exactly 5.5 TCP segments of 1460 bytes.
- #SMALL_OPTS =
--SMALL_OPTS = -DBUFSIZE=8030 -DMAXREWRITE=1030 -DSYSTEM_MAXCONN=1024
-+#SMALL_OPTS = -DBUFSIZE=8030 -DMAXREWRITE=1030 -DSYSTEM_MAXCONN=1024
-
- # redefine this if you want to add some special PATH to include/libs
- ADDINC =
-@@ -65,7 +65,7 @@
- # - use -DSTATTIME=0 to disable statistics, else specify an interval in
- # milliseconds.
- # - use -DTPROXY to compile with transparent proxy support.
--DEFINE = -DSTATTIME=0 -DTPROXY
-+#DEFINE = -DSTATTIME=0 -DTPROXY
-
- # global options
- TARGET_OPTS=$(COPTS.$(TARGET))
-@@ -75,13 +75,13 @@
- COPTS=-I. $(ADDINC) $(CPU_OPTS) $(TARGET_OPTS) $(REGEX_OPTS) $(SMALL_OPTS) $(DEFINE)
- LIBS=$(LIBS.$(TARGET)) $(LIBS.$(REGEX)) $(ADDLIB)
-
--CFLAGS = -Wall $(COPTS) $(DEBUG)
--LDFLAGS = -g
-+CFLAGS+= -Wall $(COPTS)
-+LDFLAGS+= #-g /lib/crt0.o -lc
-
- all: haproxy
-
- haproxy: src/list.o src/chtbl.o src/hashpjw.o haproxy.o src/base64.o src/uri_auth.o
-- $(LD) $(LDFLAGS) -o $@ $> $(LIBS)
-+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $> $(LIBS)
-
- src/base64.o: src/base64.c
- $(CC) $(CFLAGS) -c -o $@ $<
diff --git a/net/haproxy-devel/pkg-descr b/net/haproxy-devel/pkg-descr
deleted file mode 100644
index 4da1ab8c8502..000000000000
--- a/net/haproxy-devel/pkg-descr
+++ /dev/null
@@ -1,8 +0,0 @@
-HAproxy is a high-performance and highly-robust TCP/HTTP load balancer which
-provides cookie-based persistence, automatic failover, header insertion,
-deletion, modification on the fly, advanced logging contents to help trouble-
-shooting buggy applications and/or networks, and a few other features. It uses
-its own state machine to achieve up to ten thousands hits per second on modern
-hardware, even with thousands simultaneous connections.
-
-WWW: http://haproxy.1wt.eu/
diff --git a/net/haproxy-devel/pkg-message b/net/haproxy-devel/pkg-message
deleted file mode 100644
index 4cb845b4df81..000000000000
--- a/net/haproxy-devel/pkg-message
+++ /dev/null
@@ -1,3 +0,0 @@
-===> BE CAREFULL HOW TO BOOT on 1.1.28 or after:
- To run haproxy from startup, add haproxy_enable="YES" in your
- /etc/rc.conf.
diff --git a/net/haproxy-devel/pkg-plist b/net/haproxy-devel/pkg-plist
deleted file mode 100644
index 6431f584ff60..000000000000
--- a/net/haproxy-devel/pkg-plist
+++ /dev/null
@@ -1,7 +0,0 @@
-sbin/haproxy
-%%PORTDOCS%%%%DOCSDIR%%/architecture.txt
-%%PORTDOCS%%%%DOCSDIR%%/haproxy-en.txt
-%%PORTDOCS%%%%DOCSDIR%%/haproxy-fr.txt
-%%PORTDOCS%%%%EXAMPLESDIR%%/haproxy.cfg
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%