aboutsummaryrefslogtreecommitdiff
path: root/net/haproxy/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/haproxy/Makefile')
-rw-r--r--net/haproxy/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/net/haproxy/Makefile b/net/haproxy/Makefile
new file mode 100644
index 000000000000..0a91200a0b0a
--- /dev/null
+++ b/net/haproxy/Makefile
@@ -0,0 +1,36 @@
+# New ports collection Makefile for: haproxy
+# Date created: Apr 30, 2003
+# Whom: Clement Laforet
+#
+# $FreeBSD$
+#
+
+PORTNAME= haproxy
+PORTVERSION= 1.1.20
+PORTREVISION= 0
+CATEGORIES= net www
+MASTER_SITES= http://w.ods.org/tools/haproxy/ \
+ http://w.ods.org/tools/haproxy/old/
+
+MAINTAINER= sheepkiller@cultdeadsheep.org
+COMMENT= High-performance and highly-robust TCP/HTTP load balancer
+
+STATS_INTERVAL= 0
+REGEX_TYPE?= libc
+
+MAKE_ENV+= REGEX=${REGEX_TYPE} INTERVAL=${STATS_INTERVAL}
+
+.if defined(WITH_PCRE)
+REGEX_TYPE= pcre
+PKGNAMESUFFIX= -pcre
+LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/haproxy ${PREFIX}/sbin
+ ${INSTALL_DATA} ${WRKSRC}/examples/haproxy.cfg \
+ ${PREFIX}/etc/haproxy.cfg.sample
+ ${INSTALL_SCRIPT} ${FILESDIR}/haproxy.sh \
+ ${PREFIX}/etc/rc.d/haproxy.sh.sample
+
+.include <bsd.port.mk>