aboutsummaryrefslogtreecommitdiff
path: root/net/hping
diff options
context:
space:
mode:
Diffstat (limited to 'net/hping')
-rw-r--r--net/hping/Makefile36
-rw-r--r--net/hping/distinfo1
-rw-r--r--net/hping/files/patch-Makefile.in13
-rw-r--r--net/hping/files/patch-configure10
-rw-r--r--net/hping/files/patch-memlockall11
-rw-r--r--net/hping/files/patch-memunlockall11
-rw-r--r--net/hping/files/patch-warnings145
-rw-r--r--net/hping/pkg-descr23
-rw-r--r--net/hping/pkg-plist7
9 files changed, 0 insertions, 257 deletions
diff --git a/net/hping/Makefile b/net/hping/Makefile
deleted file mode 100644
index 4f69015871f3..000000000000
--- a/net/hping/Makefile
+++ /dev/null
@@ -1,36 +0,0 @@
-# New ports collection makefile for: hping
-# Date Created: 5 Oct 2000
-# Whom: Roman Shterenzon <roman@xpert.com>
-#
-# $FreeBSD$
-#
-
-PORTNAME= hping
-PORTVERSION= 2.0.0r2
-PORTREVISION= 2
-PORTEPOCH= 1
-CATEGORIES= security net
-MASTER_SITES= http://www.hping.org/
-DISTNAME= hping2.0.0-rc2
-
-MAINTAINER= ecu@ipv42.net
-COMMENT= Network auditing tool
-
-WRKSRC= ${WRKDIR}/hping2-rc2
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --force-libpcap
-USE_GMAKE= yes
-
-MAN8= hping.8
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/hping2 ${PREFIX}/sbin/hping
- ${INSTALL_MAN} ${WRKSRC}/docs/hping2.8 ${PREFIX}/man/man8/hping.8
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/hping
-.for i in AS-BACKDOOR HPING2-HOWTO.txt HPING2-IS-OPEN MORE-FUN-WITH-IPID SPOOFED_SCAN.txt
- ${INSTALL_DATA} ${WRKSRC}/docs/${i} ${PREFIX}/share/doc/hping/
-.endfor
-.endif
-
-.include <bsd.port.mk>
diff --git a/net/hping/distinfo b/net/hping/distinfo
deleted file mode 100644
index 56cc24b5e5cc..000000000000
--- a/net/hping/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (hping2.0.0-rc2.tar.gz) = f9ab1f84ec89f2a1c428988231d554b0
diff --git a/net/hping/files/patch-Makefile.in b/net/hping/files/patch-Makefile.in
deleted file mode 100644
index 07e0dd9d3ddc..000000000000
--- a/net/hping/files/patch-Makefile.in
+++ /dev/null
@@ -1,13 +0,0 @@
---- Makefile.in.orig Wed Aug 15 04:02:53 2001
-+++ Makefile.in Mon Nov 18 09:10:12 2002
-@@ -6,8 +6,8 @@
- # $date: Sun Jul 25 17:56:15 MET DST 1999$
- # $rev: 3$
-
--CC= gcc
--CCOPT= -O2 -Wall @PCAP_INCLUDE@
-+CC?= gcc
-+CCOPT= -Wall @CFLAGS@ @PCAP_INCLUDE@
- DEBUG= -g
- #uncomment the following if you need libpcap based build under linux
- #(not raccomanded)
diff --git a/net/hping/files/patch-configure b/net/hping/files/patch-configure
deleted file mode 100644
index b7dda57f7370..000000000000
--- a/net/hping/files/patch-configure
+++ /dev/null
@@ -1,10 +0,0 @@
---- configure.orig Fri Sep 14 22:04:25 2001
-+++ configure Fri Sep 14 22:05:02 2001
-@@ -99,6 +99,7 @@
- -e "s^@PCAP_INCLUDE@^$PCAP_INCLUDE^g" \
- -e "s^@MANPATH@^$INSTALL_MANPATH^g" \
- -e "s^@SOLARISLIB@^$SOLARISLIB^g" \
-+ -e "s^@CFLAGS@^$CFLAGS^g" \
- <Makefile.in > Makefile
-
- #
diff --git a/net/hping/files/patch-memlockall b/net/hping/files/patch-memlockall
deleted file mode 100644
index e613a3f17a22..000000000000
--- a/net/hping/files/patch-memlockall
+++ /dev/null
@@ -1,11 +0,0 @@
---- memlockall.c.orig Sun Nov 17 18:04:44 2002
-+++ memlockall.c Sun Nov 17 18:04:43 2002
-@@ -13,7 +13,7 @@
-
- int memlockall(void)
- {
--#ifdef _POSIX_MEMLOCK
-+#if _POSIX_MEMLOCK == 1
- return ( mlockall(MCL_CURRENT|MCL_FUTURE) );
- #endif
- return (-1);
diff --git a/net/hping/files/patch-memunlockall b/net/hping/files/patch-memunlockall
deleted file mode 100644
index 4a67466433f7..000000000000
--- a/net/hping/files/patch-memunlockall
+++ /dev/null
@@ -1,11 +0,0 @@
---- memunlockall.c.orig Sun Nov 17 18:04:44 2002
-+++ memunlockall.c Sun Nov 17 18:04:43 2002
-@@ -13,7 +13,7 @@
-
- int memunlockall(void)
- {
--#ifdef _POSIX_MEMLOCK
-+#if _POSIX_MEMLOCK == 1
- return ( munlockall() );
- #endif
- return(-1);
diff --git a/net/hping/files/patch-warnings b/net/hping/files/patch-warnings
deleted file mode 100644
index 4ded8a219920..000000000000
--- a/net/hping/files/patch-warnings
+++ /dev/null
@@ -1,145 +0,0 @@
-*** datafiller.c.org Sun Mar 30 13:18:24 2003
---- datafiller.c Sun Mar 30 13:20:22 2003
-***************
-*** 14,19 ****
---- 14,20 ----
- #include <sys/stat.h>
- #include <fcntl.h>
- #include <string.h> /* memset */
-+ #include <stdlib.h>
-
- #include "hping2.h"
- #include "globals.h"
-
-
-*** libpcap_stuff.c.org Sun Mar 30 13:19:42 2003
---- libpcap_stuff.c Sun Mar 30 13:25:51 2003
-***************
-*** 17,22 ****
---- 17,23 ----
- #include <sys/ioctl.h>
- #include <pcap.h>
- #include <net/bpf.h>
-+ #include <string.h>
-
- #include "globals.h"
-
-
-*** listen.c.org Sun Mar 30 13:19:24 2003
---- listen.c Sun Mar 30 13:24:31 2003
-***************
-*** 14,19 ****
---- 14,20 ----
- #include <sys/types.h>
- #include <sys/socket.h>
- #include <netinet/in.h>
-+ #include <stdlib.h>
-
- #include "hping2.h" /* hping2.h includes hcmp.h */
- #include "globals.h"
-
-
-*** resolve.c.org Sun Mar 30 13:18:51 2003
---- resolve.c Sun Mar 30 13:22:02 2003
-***************
-*** 15,20 ****
---- 15,21 ----
- #include <sys/socket.h>
- #include <netinet/in.h>
- #include <arpa/inet.h>
-+ #include <stdlib.h>
-
- void resolve (struct sockaddr * addr, char *hostname)
- {
-
-
-*** rtt.c.org Sun Mar 30 13:19:33 2003
---- rtt.c Mon Mar 31 17:32:40 2003
-***************
-*** 72,82 ****
- printf("\n\nSANITY CHECK in rtt.c FAILED!\n");
- printf("- seqnum = %d\n", *seqp);
- printf("- status = %d\n", status);
-! printf("- get_usec() = %ld\n", get_usec());
-! printf("- delaytable.usec = %ld\n", delaytable[tablepos].usec);
-! printf("- usec_delay = %ld\n", usec_delay);
-! printf("- time(NULL) = %ld\n", time(NULL));
-! printf("- delaytable.sec = %ld\n", delaytable[tablepos].sec);
- printf("- sec_delay = %ld\n", sec_delay);
- printf("- ms_delay = %f\n", *ms_delay);
- printf("END SANITY CHECK REPORT\n\n");
---- 72,83 ----
- printf("\n\nSANITY CHECK in rtt.c FAILED!\n");
- printf("- seqnum = %d\n", *seqp);
- printf("- status = %d\n", status);
-! /* time_t is __int32_t on i386 FreeBSD */
-! printf("- get_usec() = %ld\n", (long)get_usec());
-! printf("- delaytable.usec = %ld\n", (long)delaytable[tablepos].usec);
-! printf("- usec_delay = %ld\n", (long)usec_delay);
-! printf("- time(NULL) = %ld\n", (long)time(NULL));
-! printf("- delaytable.sec = %ld\n", (long)delaytable[tablepos].sec);
- printf("- sec_delay = %ld\n", sec_delay);
- printf("- ms_delay = %f\n", *ms_delay);
- printf("END SANITY CHECK REPORT\n\n");
-
-
-*** statistics.c.org Sun Mar 30 13:19:02 2003
---- statistics.c Sun Mar 30 13:22:18 2003
-***************
-*** 9,14 ****
---- 9,15 ----
- */
-
- #include <stdio.h>
-+ #include <stdlib.h>
-
- #include "hping2.h"
- #include "globals.h"
-
-
-*** version.c.org Sun Mar 30 13:19:17 2003
---- version.c Sun Mar 30 13:23:17 2003
-***************
-*** 9,14 ****
---- 9,15 ----
- */
-
- #include <stdio.h>
-+ #include <stdlib.h>
-
- #include "release.h"
- #include "hping2.h"
-
-
-*** waitpacket.c.org Sun Mar 30 13:18:32 2003
---- waitpacket.c Sun Mar 30 20:28:13 2003
-***************
-*** 13,18 ****
---- 13,19 ----
- #include <time.h>
- #include <ctype.h>
- #include <unistd.h>
-+ #include <stdlib.h>
-
- #include "hping2.h"
- #include "globals.h"
-
-*** waitpacket.c.org Sun Mar 30 13:18:32 2003
---- waitpacket.c Sun Mar 30 20:28:13 2003
-***************
-*** 179,185 ****
- (unsigned int) ntohl(icmp_tstamp.orig),
- (unsigned int) ntohl(icmp_tstamp.recv),
- (unsigned int) ntohl(icmp_tstamp.tran));
-! printf("ICMP timestamp RTT tsrtt=%lu\n\n",
- (get_midnight_ut_ms() - ntohl(icmp_tstamp.orig)));
- }
-
---- 180,186 ----
- (unsigned int) ntohl(icmp_tstamp.orig),
- (unsigned int) ntohl(icmp_tstamp.recv),
- (unsigned int) ntohl(icmp_tstamp.tran));
-! printf("ICMP timestamp RTT tsrtt=%u\n\n",
- (get_midnight_ut_ms() - ntohl(icmp_tstamp.orig)));
- }
-
diff --git a/net/hping/pkg-descr b/net/hping/pkg-descr
deleted file mode 100644
index d62dcd7dddbf..000000000000
--- a/net/hping/pkg-descr
+++ /dev/null
@@ -1,23 +0,0 @@
-hping is a command-line oriented TCP/IP packet assembler/analyzer.
-The interface is inspired to the ping(8) unix command, but hping isn't
-only able to send ICMP echo requests. It supports TCP, UDP, ICMP and
-RAW-IP protocols, has a traceroute mode, the ability to send files
-between a covered channel, and many other features.
-While hping was mainly used as a security tool in the past, it can be
-used in many ways by people that don't care about security to test
-networks and hosts. A subset of the stuff you can do using hping:
-
- - Test firewall rules
- - [spoofed] port scanning
- - Test net performance using different protocols,
- packet size, TOS (type of service) and fragmentation.
- - Path MTU discovery
- - Files transfering even between really fascist firewall rules.
- - Traceroute like under different protocols.
- - Firewalk like usage.
- - Remote OS fingerprint.
- - TCP/IP stack auditing.
-
-WWW: http://www.hping.org/
-
--- Nicolas Jombart <ecu@ipv42.net>
diff --git a/net/hping/pkg-plist b/net/hping/pkg-plist
deleted file mode 100644
index 53c3a3af705f..000000000000
--- a/net/hping/pkg-plist
+++ /dev/null
@@ -1,7 +0,0 @@
-sbin/hping
-%%PORTDOCS%%share/doc/hping/AS-BACKDOOR
-%%PORTDOCS%%share/doc/hping/HPING2-HOWTO.txt
-%%PORTDOCS%%share/doc/hping/HPING2-IS-OPEN
-%%PORTDOCS%%share/doc/hping/MORE-FUN-WITH-IPID
-%%PORTDOCS%%share/doc/hping/SPOOFED_SCAN.txt
-%%PORTDOCS%%@dirrm share/doc/hping