aboutsummaryrefslogtreecommitdiff
path: root/net/isc-dhcp40-server/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/isc-dhcp40-server/Makefile')
-rw-r--r--net/isc-dhcp40-server/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/net/isc-dhcp40-server/Makefile b/net/isc-dhcp40-server/Makefile
index d9f92558eff6..1b0d74a28f4c 100644
--- a/net/isc-dhcp40-server/Makefile
+++ b/net/isc-dhcp40-server/Makefile
@@ -1,3 +1,4 @@
+# ex:ts=8
# Ports collection makefile for: dhcp
# Date created: 7 Mar 1996
# Whom: se
@@ -5,13 +6,13 @@
# $FreeBSD$
#
-PORTNAME= isc-dhcp
-PORTVERSION= 2.0
+PORTNAME= isc-dhcp3
+PORTVERSION= 3.0.b1.13
CATEGORIES= net
MASTER_SITES= ftp://ftp.isc.org/isc/dhcp/
-DISTNAME= dhcp-${PORTVERSION}
+DISTNAME= dhcp-3.0b1pl13
-MAINTAINER= jseger@FreeBSD.org
+MAINTAINER= obrien@FreeBSD.org
Y2K= http://www.isc.org/y2k.html
@@ -21,6 +22,9 @@ MAN5= dhclient.conf.5 dhclient.leases.5 dhcp-options.5 dhcpd.conf.5 \
dhcpd.leases.5
MAN8= dhclient.8 dhclient-script.8 dhcpd.8 dhcrelay.8
+post-patch:
+ @${PERL} -pi.fbsd -e 's.!!PREFIX!!.${PREFIX}.g' ${WRKSRC}/includes/dhcpd.h
+
post-install:
${TOUCH} /var/db/dhcpd.leases
.for file in dhclient dhcpd dhcrelay