aboutsummaryrefslogtreecommitdiff
path: root/net/isc-dhcp40-server/files/patch-dst::Makefile.dist
diff options
context:
space:
mode:
Diffstat (limited to 'net/isc-dhcp40-server/files/patch-dst::Makefile.dist')
-rw-r--r--net/isc-dhcp40-server/files/patch-dst::Makefile.dist29
1 files changed, 29 insertions, 0 deletions
diff --git a/net/isc-dhcp40-server/files/patch-dst::Makefile.dist b/net/isc-dhcp40-server/files/patch-dst::Makefile.dist
new file mode 100644
index 000000000000..ad45436b1629
--- /dev/null
+++ b/net/isc-dhcp40-server/files/patch-dst::Makefile.dist
@@ -0,0 +1,29 @@
+--- dst/Makefile.dist.orig Sun Nov 17 03:27:43 2002
++++ dst/Makefile.dist Fri Mar 5 23:40:45 2004
+@@ -26,12 +26,24 @@
+
+ all: libdst.a
+
+-install:
+-
+ libdst.a: $(OBJ)
+ rm -f dst.a
+ ar cruv libdst.a $(OBJ)
+ $(RANLIB) libdst.a
++
++install: all
++ for dir in $(LIBDIR);\
++ do \
++ foo=""; \
++ for bar in `echo $(DESTDIR)$${dir} |tr / ' '`; do \
++ foo=$${foo}/$$bar; \
++ if [ ! -d $$foo ]; then \
++ mkdir $$foo; \
++ chmod 755 $$foo; \
++ fi; \
++ done; \
++ done
++ $(INSTALL) libdst.a $(DESTDIR)$(LIBDIR)
+
+ depend:
+ $(MKDEP) $(INCLUDES) $(PREDEFINES) $(SRC)