aboutsummaryrefslogtreecommitdiff
path: root/net/jwhois
diff options
context:
space:
mode:
Diffstat (limited to 'net/jwhois')
-rw-r--r--net/jwhois/Makefile3
-rw-r--r--net/jwhois/distinfo2
-rw-r--r--net/jwhois/files/patch-3.1.0-fix48
-rw-r--r--net/jwhois/files/patch-ac11
-rw-r--r--net/jwhois/pkg-plist3
5 files changed, 65 insertions, 2 deletions
diff --git a/net/jwhois/Makefile b/net/jwhois/Makefile
index 6285ae78cc69..de6bb462d57d 100644
--- a/net/jwhois/Makefile
+++ b/net/jwhois/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= jwhois
-PORTVERSION= 3.0.1
+PORTVERSION= 3.1.0
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= jwhois
@@ -22,6 +22,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${PREFIX}/include" LDFLAGS="-L${PREFIX}/lib"
INSTALL_TARGET= install-strip
+MANLANG= "" sv
MAN1= jwhois.1
post-install:
diff --git a/net/jwhois/distinfo b/net/jwhois/distinfo
index 5b1aeecc70c1..d724d0c369f6 100644
--- a/net/jwhois/distinfo
+++ b/net/jwhois/distinfo
@@ -1 +1 @@
-MD5 (jwhois-3.0.1.tar.gz) = 036186fda42ecd6363bbbeba895b07b7
+MD5 (jwhois-3.1.0.tar.gz) = b33c23aeec9093ef5efaf1a97d69135c
diff --git a/net/jwhois/files/patch-3.1.0-fix b/net/jwhois/files/patch-3.1.0-fix
new file mode 100644
index 000000000000..9bd7d1741ad5
--- /dev/null
+++ b/net/jwhois/files/patch-3.1.0-fix
@@ -0,0 +1,48 @@
+Index: example/jwhois.conf
+===================================================================
+RCS file: /cvsroot/jwhois/jwhois/example/jwhois.conf,v
+retrieving revision 1.54
+retrieving revision 1.55
+diff -u -r1.54 -r1.55
+--- example/jwhois.conf 8 Dec 2001 17:34:25 -0000 1.54
++++ example/jwhois.conf 13 Jan 2002 14:57:22 -0000 1.55
+@@ -391,8 +391,9 @@
+ "www\\.dk-hostmaster\\.dk" {
+ http = "true";
+ http-method = "GET";
+- http-action = "/perl/Whois.pl";
++ http-action = "/scripts/whois.php";
+ form-element = "query";
++ form-extra = "lang=en";
+ }
+
+ "www\\.nic\\.es" {
+Index: src/rwhois.c
+===================================================================
+RCS file: /cvsroot/jwhois/jwhois/src/rwhois.c,v
+retrieving revision 1.11
+retrieving revision 1.12
+diff -u -r1.11 -r1.12
+--- src/rwhois.c 5 Jan 2002 23:41:30 -0000 1.11
++++ src/rwhois.c 6 Feb 2002 17:32:07 -0000 1.12
+@@ -414,7 +414,7 @@
+ int
+ rwhois_parse_line(const char *reply, char **text)
+ {
+- char *capab, *tmpptr;
++ char *tmpptr;
+
+ tmpptr = (char *)strchr(reply, '\n');
+ if (tmpptr)
+@@ -427,9 +427,10 @@
+ }
+ if (strncasecmp(reply, "%rwhois", 7) == 0)
+ {
+- capab = (char *)strchr(reply, ':')+1;
++ char *capab = (char *)strchr(reply, ':');
+ if (!capab)
+ return REP_ERROR;
++ capab++; /* skip past first : */
+ tmpptr = (char *)strchr(capab, ':');
+ if (!tmpptr)
+ return REP_ERROR;
diff --git a/net/jwhois/files/patch-ac b/net/jwhois/files/patch-ac
new file mode 100644
index 000000000000..8812018fe54f
--- /dev/null
+++ b/net/jwhois/files/patch-ac
@@ -0,0 +1,11 @@
+--- Makefile.in.dist Thu Jan 10 03:50:32 2002
++++ Makefile.in Sat Feb 9 18:07:56 2002
+@@ -99,7 +99,7 @@
+ sgid = @sgid@
+
+ EXTRA_DIST = include/*.h example/jwhois.conf macros/*.m4 jwhois.spec.in jwhois.spec
+-SUBDIRS = doc intl src example @POSUB@
++SUBDIRS = doc intl src @POSUB@
+ subdir = .
+ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
diff --git a/net/jwhois/pkg-plist b/net/jwhois/pkg-plist
index 660fcce8671e..2c89883003ff 100644
--- a/net/jwhois/pkg-plist
+++ b/net/jwhois/pkg-plist
@@ -5,6 +5,8 @@ etc/jwhois.conf.sample
@unexec install-info --delete %D/info/jwhois.info %D/info/dir
info/jwhois.info
@exec install-info %D/info/jwhois.info %D/info/dir
+share/locale/es/LC_MESSAGES/jwhois.mo
+share/locale/fr/LC_MESSAGES/jwhois.mo
share/locale/ru/LC_MESSAGES/jwhois.mo
share/locale/sv/LC_MESSAGES/jwhois.mo
@unexec rmdir %D/share/locale/*/LC_MESSAGES 2>/dev/null || true
@@ -13,3 +15,4 @@ share/locale/sv/LC_MESSAGES/jwhois.mo
@unexec rm -f %D/var/jwhois/jwhois.db 2>/dev/null || true
@unexec rmdir %D/var/jwhois 2>/dev/null || true
@unexec rmdir %D/var 2>/dev/null || true
+@unexec rmdir -p %D/man/sv/man1 2>/dev/null || true