aboutsummaryrefslogtreecommitdiff
path: root/net/kdenetwork3/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/kdenetwork3/Makefile')
-rw-r--r--net/kdenetwork3/Makefile74
1 files changed, 0 insertions, 74 deletions
diff --git a/net/kdenetwork3/Makefile b/net/kdenetwork3/Makefile
deleted file mode 100644
index f10e68ff3f3a..000000000000
--- a/net/kdenetwork3/Makefile
+++ /dev/null
@@ -1,74 +0,0 @@
-# -*-mode: makefile-*-
-# New ports collection makefile for: kdenetwork2
-# Date created: 2 November 2001
-# Whom: will@cvs.kde.org
-#
-# $FreeBSD$
-#
-
-PORTNAME= kdenetwork
-PORTVERSION= ${KDE_VERSION}
-PORTREVISION= 4
-CATEGORIES?= net kde
-MASTER_SITES= ${MASTER_SITE_KDE}
-MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
-DIST_SUBDIR= KDE
-
-MAINTAINER?= ports@FreeBSD.org
-COMMENT= Network-related programs and modules for KDE
-
-LIB_DEPENDS= slp:${PORTSDIR}/net/openslp
-
-DEPRECATED= Depends on QT3; unmaintained
-EXPIRATION_DATE= 2013-07-01
-
-OPTIONS_DEFINE= KOPETE
-KOPETE_DESC= Install kopete multi-protocol instant messenger
-
-USE_KDELIBS_VER=3
-USE_PERL5= yes
-USE_BZIP2= yes
-USE_GMAKE= yes
-USE_OPENSSL= yes
-USE_XORG= xtst
-
-USE_AUTOTOOLS= libtool
-USE_LDCONFIG= yes
-DO_NOT_COMPILE+=kopete lanbrowsing filesharing
-
-CONFIGURE_ARGS+=--with-ssl-dir=${OPENSSLBASE}
-
-.if defined(DO_NOT_COMPILE)
-CONFIGURE_ENV+= DO_NOT_COMPILE="${DO_NOT_COMPILE}"
-.endif # defined(DO_NOT_COMPILE)
-
-.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
-.include <bsd.port.pre.mk>
-
-DO_NOT_COMPILE+= kppp
-PLIST_SUB+= KPPP="@comment "
-KPPP=
-
-.if ${OSVERSION} >= 900004
-EXTRA_PATCHES+= ${FILESDIR}/extrapatch-find_user.cpp
-.endif
-
-pre-configure:
- @${REINPLACE_CMD} \
- -E -e '/^SUBDIRS/s/lisa//g' \
- -e '/^SUBDIRS/s/kppp/${KPPP}/g' \
- ${WRKSRC}/doc/Makefile.in
- @${REINPLACE_CMD} \
- -e 's|/etc/security/|${LOCALBASE}/etc/|g' \
- ${WRKSRC}/filesharing/advanced/kcm_sambaconf/kcmsambaconf.cpp \
- ${WRKSRC}/filesharing/simple/fileshare.cpp
-
-##
-# OPTIONS handling
-##
-#
-.if ${PORT_OPTIONS:MKOPETE}
-RUN_DEPENDS+= kopete:${PORTSDIR}/net-im/kopete
-.endif
-
-.include <bsd.port.post.mk>