aboutsummaryrefslogtreecommitdiff
path: root/net/kdenetwork3/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/kdenetwork3/Makefile')
-rw-r--r--net/kdenetwork3/Makefile23
1 files changed, 11 insertions, 12 deletions
diff --git a/net/kdenetwork3/Makefile b/net/kdenetwork3/Makefile
index ebc3116f3eb9..2ea7c8318182 100644
--- a/net/kdenetwork3/Makefile
+++ b/net/kdenetwork3/Makefile
@@ -8,7 +8,7 @@
PORTNAME= kdenetwork
PORTVERSION= ${KDE_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES?= net kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
@@ -17,11 +17,9 @@ DIST_SUBDIR= KDE
MAINTAINER?= kde@FreeBSD.org
COMMENT= Network-related programs and modules for KDE
-LIB_DEPENDS= idn:${PORTSDIR}/dns/libidn \
- slp:${PORTSDIR}/net/openslp
-RUN_DEPENDS= ${QT_PREFIX}/lib/plugins/crypto/libqca-tls.so:${PORTSDIR}/security/qca-tls
+LIB_DEPENDS= slp:${PORTSDIR}/net/openslp
-CONFLICTS= kopete-[0-9]* kvirc-[0-9]*
+OPTIONS= KOPETE "Install kopete multi-protocol instant messenger" OFF
USE_KDELIBS_VER=3
PREFIX= ${KDE_PREFIX}
@@ -34,10 +32,9 @@ USE_OPENSSL= yes
USE_AUTOTOOLS= libtool:15
INSTALLS_SHLIB= yes
LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
-DO_NOT_COMPILE+=lanbrowsing
-_NO_KDE_FINAL= yes
+DO_NOT_COMPILE+=kopete lanbrowsing
-CONFIGURE_ARGS+=--with-ssl-dir=/
+CONFIGURE_ARGS+=--with-ssl-dir=${OPENSSLBASE}
.if defined(DO_NOT_COMPILE)
CONFIGURE_ENV+=DO_NOT_COMPILE="${DO_NOT_COMPILE}"
@@ -51,10 +48,12 @@ pre-configure:
-E -e '/^SUBDIRS/s/lisa//g' \
${WRKSRC}/doc/Makefile.in
-post-configure:
-.if ${OSVERSION} < 500028
- @${REINPLACE_CMD} -e 's|$$(depcomp)||g' \
- ${WRKSRC}/kopete/protocols/jabber/libiris/iris/xmpp-core/Makefile
+##
+# OPTIONS handling
+##
+#
+.if defined(WITH_KOPETE)
+RUN_DEPENDS+= kopete:${PORTSDIR}/net-im/kopete
.endif
.include <bsd.port.post.mk>