aboutsummaryrefslogtreecommitdiff
path: root/net/kdenetwork3
diff options
context:
space:
mode:
Diffstat (limited to 'net/kdenetwork3')
-rw-r--r--net/kdenetwork3/Makefile1
-rw-r--r--net/kdenetwork3/files/patch-kopete_protocols_yahoo_libyahoo2_libyahoo2.c19
-rw-r--r--net/kdenetwork3/files/patch-kopete_protocols_yahoo_libyahoo2_yahoo_fn.c19
3 files changed, 39 insertions, 0 deletions
diff --git a/net/kdenetwork3/Makefile b/net/kdenetwork3/Makefile
index 91b938f6c064..6926d39a256d 100644
--- a/net/kdenetwork3/Makefile
+++ b/net/kdenetwork3/Makefile
@@ -8,6 +8,7 @@
PORTNAME= kdenetwork
PORTVERSION= ${KDE_VERSION}
+PORTREVISION= 1
CATEGORIES?= net kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
diff --git a/net/kdenetwork3/files/patch-kopete_protocols_yahoo_libyahoo2_libyahoo2.c b/net/kdenetwork3/files/patch-kopete_protocols_yahoo_libyahoo2_libyahoo2.c
new file mode 100644
index 000000000000..9d93cb79db9a
--- /dev/null
+++ b/net/kdenetwork3/files/patch-kopete_protocols_yahoo_libyahoo2_libyahoo2.c
@@ -0,0 +1,19 @@
+--- kopete/protocols/yahoo/libyahoo2/libyahoo2.c 14 Jan 2004 02:07:29 -0000 1.18
++++ kopete/protocols/yahoo/libyahoo2/libyahoo2.c 26 Jun 2004 00:37:08 -0000 1.18.2.3
+@@ -1816,6 +1816,8 @@ static void yahoo_process_auth_0x0b(stru
+ * challenge. */
+
+ shaUpdate(&ctx1, pass_hash_xor1, 64);
++ if (j >= 3 )
++ ctx1.sizeLo = 0x1ff;
+ shaUpdate(&ctx1, magic_key_char, 4);
+ shaFinal(&ctx1, digest1);
+
+@@ -1905,6 +1907,8 @@ static void yahoo_process_auth_0x0b(stru
+ * challenge. */
+
+ shaUpdate(&ctx1, crypt_hash_xor1, 64);
++ if (j >= 3 )
++ ctx1.sizeLo = 0x1ff;
+ shaUpdate(&ctx1, magic_key_char, 4);
+ shaFinal(&ctx1, digest1);
diff --git a/net/kdenetwork3/files/patch-kopete_protocols_yahoo_libyahoo2_yahoo_fn.c b/net/kdenetwork3/files/patch-kopete_protocols_yahoo_libyahoo2_yahoo_fn.c
new file mode 100644
index 000000000000..9d93cb79db9a
--- /dev/null
+++ b/net/kdenetwork3/files/patch-kopete_protocols_yahoo_libyahoo2_yahoo_fn.c
@@ -0,0 +1,19 @@
+--- kopete/protocols/yahoo/libyahoo2/libyahoo2.c 14 Jan 2004 02:07:29 -0000 1.18
++++ kopete/protocols/yahoo/libyahoo2/libyahoo2.c 26 Jun 2004 00:37:08 -0000 1.18.2.3
+@@ -1816,6 +1816,8 @@ static void yahoo_process_auth_0x0b(stru
+ * challenge. */
+
+ shaUpdate(&ctx1, pass_hash_xor1, 64);
++ if (j >= 3 )
++ ctx1.sizeLo = 0x1ff;
+ shaUpdate(&ctx1, magic_key_char, 4);
+ shaFinal(&ctx1, digest1);
+
+@@ -1905,6 +1907,8 @@ static void yahoo_process_auth_0x0b(stru
+ * challenge. */
+
+ shaUpdate(&ctx1, crypt_hash_xor1, 64);
++ if (j >= 3 )
++ ctx1.sizeLo = 0x1ff;
+ shaUpdate(&ctx1, magic_key_char, 4);
+ shaFinal(&ctx1, digest1);