aboutsummaryrefslogtreecommitdiff
path: root/net/kdenetwork4/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/kdenetwork4/Makefile')
-rw-r--r--net/kdenetwork4/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/net/kdenetwork4/Makefile b/net/kdenetwork4/Makefile
index 1847c939eb92..77dba4dc9b97 100644
--- a/net/kdenetwork4/Makefile
+++ b/net/kdenetwork4/Makefile
@@ -24,12 +24,13 @@ USE_AUTOCONF= yes
CONFIGURE_ARGS+=--with-qt-includes=${X11BASE}/include/qt2 \
--with-qt-libraries=${X11BASE}/lib \
--with-extra-libs=${LOCALBASE}/lib
-CONFIGURE_ENV+= LIBQT="-lqt2" MOC="${MOC}" LIBQTFILE="libqt2" \
- CPPFLAGS="-I${LOCALBASE}/include -D_GETOPT_H -D_XOPEN_UNIX" \
+CONFIGURE_ENV+= LIBQT="-lqt2" MOC="${MOC}" \
+ CPPFLAGS="-I/usr/include -D_PTH_H_ -D_PTH_PTHREAD_H_ -D_GETOPT_H -D_XOPEN_UNIX -I${LOCALBASE}/include" \
LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lgcc -lstdc++"
USE_GMAKE= yes
pre-configure:
${PERL} -pi -e "s:-lpthread:-pthread:g" ${WRKSRC}/knode/Makefile.in
+ ${PERL} -pi -e "s@all_includes=\"@all_includes=\"-I/usr/include @g" ${WRKSRC}/acinclude.m4 ${WRKSRC}/aclocal.m4
.include <bsd.port.mk>