aboutsummaryrefslogtreecommitdiff
path: root/net/kitinerary/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/kitinerary/Makefile')
-rw-r--r--net/kitinerary/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/net/kitinerary/Makefile b/net/kitinerary/Makefile
new file mode 100644
index 000000000000..59fd07000980
--- /dev/null
+++ b/net/kitinerary/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= kitinerary
+DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+CATEGORIES= net kde kde-applications
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Data Model and Extraction System for Travel Reservation information
+
+LICENSE= LGPL21
+
+LIB_DEPENDS= libpoppler.so:graphics/poppler \
+ libzxing.so:textproc/zxing-cpp
+
+USES= cmake:outsource gettext kde:5 pkgconfig qt:5 tar:xz
+USE_KDE= ecm i18n
+# Pim components
+USE_KDE+= calendarcore contacts kpkpass mime
+USE_QT= core qml \
+ buildtools_build qmake_build
+USE_LDCONFIG= yes
+
+DESCR= ${.CURDIR:H:H}/deskutils/kdepim/pkg-descr
+
+
+.include <bsd.port.mk>