aboutsummaryrefslogtreecommitdiff
path: root/net/libcmis/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/libcmis/Makefile')
-rw-r--r--net/libcmis/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/net/libcmis/Makefile b/net/libcmis/Makefile
new file mode 100644
index 000000000000..45c45a0bbf4b
--- /dev/null
+++ b/net/libcmis/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: libcmis
+# Date created: 2012-01-22
+# Whom: Baptiste Daroussin <bapt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libcmis
+PORTVERSION= 0.1.0
+CATEGORIES= net devel
+MASTER_SITES= SF/${PORTNAME}
+
+MAINTAINER= office@FreeBSD.org
+COMMENT= Client library for the CMIS interface
+
+LIB_DEPENDS= curl.6:${PORTSDIR}/ftp/curl
+BUILD_DEPENDS= ${LOCALBASE}/lib/libcppunit.so:${PORTSDIR}/devel/cppunit \
+ ${LOCALBASE}/lib/libboost_regex.a:${PORTSDIR}/devel/boost-libs
+
+GNU_CONFIGURE= yes
+USE_GNOME= libxml2 gnomehack
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>