aboutsummaryrefslogtreecommitdiff
path: root/net/libnatpmp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/libnatpmp/Makefile')
-rw-r--r--net/libnatpmp/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/net/libnatpmp/Makefile b/net/libnatpmp/Makefile
index 8646b74689bf..44e3a8eb0a32 100644
--- a/net/libnatpmp/Makefile
+++ b/net/libnatpmp/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= libnatpmp
-PORTVERSION= 20120821
+PORTVERSION= 20140401
CATEGORIES= net
MASTER_SITES= http://miniupnp.free.fr/files/
@@ -14,7 +14,8 @@ LICENSE= BSD3CLAUSE
USES= gmake
USE_LDCONFIG= yes
-MAKE_ENV+= INSTALLPREFIX=${PREFIX}
+MAKE_ARGS+= CC="${CC}"
+MAKE_ENV+= INSTALLPREFIX=${STAGEDIR}${PREFIX}
CFLAGS+= -fPIC
@@ -24,6 +25,11 @@ PLIST_FILES= bin/natpmpc \
lib/libnatpmp.so \
lib/libnatpmp.so.1
+post-patch:
+ @${REINPLACE_CMD} -e 's/^LIBSPEC //' \
+ -e '/declspec\.h/d' \
+ ${WRKSRC}/natpmp.h
+
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/natpmpc \
${STAGEDIR}${PREFIX}/lib/libnatpmp.so.1