aboutsummaryrefslogtreecommitdiff
path: root/net/libnet
diff options
context:
space:
mode:
Diffstat (limited to 'net/libnet')
-rw-r--r--net/libnet/Makefile34
-rw-r--r--net/libnet/distinfo4
-rw-r--r--net/libnet/files/patch-aa29
-rw-r--r--net/libnet/files/patch-ab20
-rw-r--r--net/libnet/files/patch-ac11
-rw-r--r--net/libnet/files/patch-include::libnet.h15
-rw-r--r--net/libnet/pkg-descr25
-rw-r--r--net/libnet/pkg-plist111
8 files changed, 122 insertions, 127 deletions
diff --git a/net/libnet/Makefile b/net/libnet/Makefile
index 1e2c60b510bb..f6e2b4fd96bd 100644
--- a/net/libnet/Makefile
+++ b/net/libnet/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libnet
-PORTVERSION= 1.0.2a
+PORTVERSION= 1.1.2.1
PORTEPOCH= 1
CATEGORIES= net
MASTER_SITES= http://www.packetfactory.net/libnet/dist/
@@ -14,28 +14,26 @@ MASTER_SITES= http://www.packetfactory.net/libnet/dist/
MAINTAINER= shipley@dis.org
COMMENT= A C library for creating IP packets
-CONFLICTS= libnet-devel-1.1.*
+CONFLICTS= libnet-devel-1.1.*\
+ libnet10-1.0.*
-USE_AUTOCONF_VER= 213
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-WRKSRC= ${WRKDIR}/Libnet-${PORTVERSION}
-MAN3= libnet.3
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+DOCS= README doc/BUGS doc/CHANGELOG doc/CONTRIB doc/COPYING \
+ doc/DESIGN_NOTES doc/MIGRATION doc/PACKET_BUILDING doc/PORTED \
+ doc/RAWSOCKET_NON_SEQUITUR doc/TODO doc/html/*
+EXAMPLES= sample/*.c
post-install:
- ${INSTALL_MAN} ${WRKSRC}/doc/libnet.3 ${PREFIX}/man/man3
+ ${INSTALL_SCRIPT} ${WRKSRC}/libnet-config ${PREFIX}/bin
+ @${MKDIR} ${EXAMPLESDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${EXAMPLES} ${EXAMPLESDIR}
.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/libnet
- @${MKDIR} ${PREFIX}/share/doc/libnet/examples
- @${MKDIR} ${PREFIX}/share/doc/libnet/ancillary
-.for i in CHANGELOG CHANGELOG-NEWFUNCTIONS COPYING README TODO-1.0 TODO-1.1
- ${INSTALL_DATA} ${WRKSRC}/doc/${i} ${PREFIX}/share/doc/libnet
-.endfor
-.for i in README.asn.1 README.bpf README.legacy-applications README.libnet-config README.linux README.rawsockets
- ${INSTALL_DATA} ${WRKSRC}/doc/Ancillary/${i} ${PREFIX}/share/doc/libnet/ancillary
-.endfor
-.for i in libnet-example-1.c libnet-example-2.c libnet-example-3.c libnet-example-4.c
- ${INSTALL_DATA} ${WRKSRC}/example/${i} ${PREFIX}/share/doc/libnet/examples
-.endfor
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/net/libnet/distinfo b/net/libnet/distinfo
index 9b65812d77a9..10bbe3fca2cd 100644
--- a/net/libnet/distinfo
+++ b/net/libnet/distinfo
@@ -1,2 +1,2 @@
-MD5 (libnet-1.0.2a.tar.gz) = ddf53f0f484184390e8c2a1bd0853667
-SIZE (libnet-1.0.2a.tar.gz) = 140191
+MD5 (libnet-1.1.2.1.tar.gz) = be845c41170d72c7db524f3411b50256
+SIZE (libnet-1.1.2.1.tar.gz) = 1021236
diff --git a/net/libnet/files/patch-aa b/net/libnet/files/patch-aa
deleted file mode 100644
index 57137897cbc7..000000000000
--- a/net/libnet/files/patch-aa
+++ /dev/null
@@ -1,29 +0,0 @@
---- configure.in.orig Wed Jan 17 12:59:30 2001
-+++ configure.in Mon Jul 2 19:18:50 2001
-@@ -50,10 +50,10 @@
- dnl Use these compiler flags if we have gcc.
- dnl
- if test $ac_cv_prog_gcc = yes; then
--dnl if test -z $CFLAGS; then
-- CCOPTS='-O2 -funroll-loops -fomit-frame-pointer -Wall'
-- CFLAGS="$CCOPTS"
--dnl fi
-+ if test -z "$CFLAGS"; then
-+ CCOPTS='-O2 -funroll-loops -fomit-frame-pointer -Wall'
-+ CFLAGS="$CCOPTS"
-+ fi
- fi
-
- dnl
-@@ -163,8 +163,9 @@
- LIB_PREFIX="$prefix/lib/aout"
- INC_PREFIX="$prefix/include/"
- BIN_PREFIX="$prefix/bin/"
-- AC_MSG_RESULT(Note: support/bpf-lkm/etherspoof contains the lkm source \
--required to spoof ethernet frames)
-+dnl etherspoof lkm is horrible and only necesary on < RELENG_4
-+dnl AC_MSG_RESULT(Note: support/bpf-lkm/etherspoof contains the lkm source \
-+dnl required to spoof ethernet frames)
- ln -sf FreeBSD support/bpf-lkm/etherspoof
- ;;
-
diff --git a/net/libnet/files/patch-ab b/net/libnet/files/patch-ab
deleted file mode 100644
index 9106f9921b2a..000000000000
--- a/net/libnet/files/patch-ab
+++ /dev/null
@@ -1,20 +0,0 @@
---- Makefile.in.orig Mon Feb 5 09:51:41 2001
-+++ Makefile.in Mon Jul 2 19:41:27 2001
-@@ -96,7 +96,7 @@
- $(ENSUREDIR) $(DESTDIR)$(LIB_PREFIX) 755
- $(ENSUREDIR) $(DESTDIR)$(INC_PREFIX)$(LIBNET) 755
- $(ENSUREDIR) $(DESTDIR)$(INC_PREFIX) 755
-- $(ENSUREDIR) $(DESTDIR)$(MAN_PREFIX) 755
-+# $(ENSUREDIR) $(DESTDIR)$(MAN_PREFIX) 755
- $(ENSUREDIR) $(DESTDIR)$(BIN_PREFIX) 755
- $(INSTALL_DATA) $(LIB) $(DESTDIR)$(LIB_PREFIX)
- rm -f $(DESTDIR)$(LIB_PREFIX)$(LIBPWRITE).a
-@@ -108,7 +108,7 @@
- $(INSTALL_DATA) $(INCLUDE-M) $(DESTDIR)$(INC_PREFIX)$(LIBNET)
- $(INSTALL_DATA) $(INCLUDE-A) $(DESTDIR)$(INC_PREFIX)$(LIBNET)
- $(INSTALL_DATA) $(INCLUDE-O) $(DESTDIR)$(INC_PREFIX)$(LIBNET)
-- $(INSTALL_DATA) $(MAN) $(DESTDIR)$(MAN_PREFIX)
-+# $(INSTALL_DATA) $(MAN) $(DESTDIR)$(MAN_PREFIX)
- $(INSTALL_DATA) $(CONFIG) $(DESTDIR)$(BIN_PREFIX)
-
-
diff --git a/net/libnet/files/patch-ac b/net/libnet/files/patch-ac
deleted file mode 100644
index f46b75aa79ca..000000000000
--- a/net/libnet/files/patch-ac
+++ /dev/null
@@ -1,11 +0,0 @@
---- include/libnet/libnet-functions.h.orig Fri Jun 7 00:31:29 2002
-+++ include/libnet/libnet-functions.h Fri Jun 7 00:31:41 2002
-@@ -74,7 +74,7 @@
- int, /* severity */
- char *, /* error message */
- ... /* varargs */
-- );
-+ ) __printflike(2, 3);
-
-
- /*
diff --git a/net/libnet/files/patch-include::libnet.h b/net/libnet/files/patch-include::libnet.h
deleted file mode 100644
index e33a86fa3ecc..000000000000
--- a/net/libnet/files/patch-include::libnet.h
+++ /dev/null
@@ -1,15 +0,0 @@
---- include/libnet.h.orig Fri Jul 18 15:11:05 2003
-+++ include/libnet.h Fri Jul 18 15:12:16 2003
-@@ -84,9 +84,9 @@
- #define LIBNET_VERSION "1.0.2a"
-
- #if (!LIBNET_LIL_ENDIAN && !LIBNET_BIG_ENDIAN)
--#error "byte order has not been specified, you'll
--need to #define either LIBNET_LIL_ENDIAN or LIBNET_BIG_ENDIAN. See the
--documentation regarding the libnet-config script."
-+#error "byte order has not been specified, you'll"
-+"need to #define either LIBNET_LIL_ENDIAN or LIBNET_BIG_ENDIAN. See the"
-+"documentation regarding the libnet-config script."
- #endif
-
- #endif /* __LIBNET_H */
diff --git a/net/libnet/pkg-descr b/net/libnet/pkg-descr
index 8d5811f3c0fe..abe227681c3d 100644
--- a/net/libnet/pkg-descr
+++ b/net/libnet/pkg-descr
@@ -1,17 +1,20 @@
-Libnet A C library for portable packet creation
+Libnet is a high-level API (toolkit) allowing the application programmer to
+construct and inject network packets. It provides a portable and simplified
+interface for low-level network packet shaping, handling and injection.
-domains of sockets and protocols.
-
-A C library for portable packet creation
-
-Included are also simple example test programs
-
-Libnet is a collection of routines to help with the construction
-and handling of network packets. It provides a portable framework
-for low-level network packet writing and handling.
+Libnet hides much of the tedium of packet creation from the application
+programmer such as multiplexing, buffer management, arcane packet header
+information, byte-ordering, OS-dependent issues, and much more.
Libnet features portable packet creation interfaces at the IP layer
and link layer, as well as a host of supplementary and complementary
functionality.
-WWW: http://www.packetfactory.net/projects/libnet/
+Using libnet, quick and simple packet assembly applications can be whipped up
+with little effort. With a bit more time, more complex programs can be written
+(Traceroute and ping were easily rewritten using libnet and libpcap).
+
+Libnet is distrubuted under the BSD license.
+
+Author: Mike D. Schiffman <mike at infonexus dot com>
+WWW: http://www.packetfactory.net/projects/libnet/
diff --git a/net/libnet/pkg-plist b/net/libnet/pkg-plist
index 212baac7b536..d34cc252a33a 100644
--- a/net/libnet/pkg-plist
+++ b/net/libnet/pkg-plist
@@ -4,27 +4,96 @@ include/libnet/libnet-asn1.h
include/libnet/libnet-functions.h
include/libnet/libnet-headers.h
include/libnet/libnet-macros.h
-include/libnet/libnet-ospf.h
include/libnet/libnet-structures.h
+include/libnet/libnet-types.h
lib/libnet.a
-lib/libpwrite.a
-share/doc/libnet/CHANGELOG
-share/doc/libnet/CHANGELOG-NEWFUNCTIONS
-share/doc/libnet/COPYING
-share/doc/libnet/README
-share/doc/libnet/TODO-1.0
-share/doc/libnet/TODO-1.1
-share/doc/libnet/examples/libnet-example-1.c
-share/doc/libnet/examples/libnet-example-2.c
-share/doc/libnet/examples/libnet-example-3.c
-share/doc/libnet/examples/libnet-example-4.c
-share/doc/libnet/ancillary/README.asn.1
-share/doc/libnet/ancillary/README.bpf
-share/doc/libnet/ancillary/README.legacy-applications
-share/doc/libnet/ancillary/README.libnet-config
-share/doc/libnet/ancillary/README.linux
-share/doc/libnet/ancillary/README.rawsockets
-@dirrm share/doc/libnet/ancillary
-@dirrm share/doc/libnet/examples
-@dirrm share/doc/libnet
+%%PORTDOCS%%%%DOCSDIR%%/BUGS
+%%PORTDOCS%%%%DOCSDIR%%/CHANGELOG
+%%PORTDOCS%%%%DOCSDIR%%/CONTRIB
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/DESIGN_NOTES
+%%PORTDOCS%%%%DOCSDIR%%/MIGRATION
+%%PORTDOCS%%%%DOCSDIR%%/PACKET_BUILDING
+%%PORTDOCS%%%%DOCSDIR%%/PORTED
+%%PORTDOCS%%%%DOCSDIR%%/RAWSOCKET_NON_SEQUITUR
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%%%DOCSDIR%%/acconfig_8h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/annotated.html
+%%PORTDOCS%%%%DOCSDIR%%/bpf_8h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/config_8h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/doxygen.css
+%%PORTDOCS%%%%DOCSDIR%%/doxygen.png
+%%PORTDOCS%%%%DOCSDIR%%/files.html
+%%PORTDOCS%%%%DOCSDIR%%/functions.html
+%%PORTDOCS%%%%DOCSDIR%%/functions_vars.html
+%%PORTDOCS%%%%DOCSDIR%%/getopt_8h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/globals.html
+%%PORTDOCS%%%%DOCSDIR%%/globals_defs.html
+%%PORTDOCS%%%%DOCSDIR%%/globals_func.html
+%%PORTDOCS%%%%DOCSDIR%%/gnuc_8h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/graph_legend.dot
+%%PORTDOCS%%%%DOCSDIR%%/graph_legend.html
+%%PORTDOCS%%%%DOCSDIR%%/ifaddrlist_8h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/in__systm_8h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/libnet-asn1_8h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/libnet-functions_8h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/libnet-functions_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/libnet-headers_8h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/libnet-headers_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/libnet-macros_8h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/libnet-macros_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/libnet-structures_8h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/libnet-types_8h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/libnet_8h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/libnet_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/structlibnet__802__1q__hdr.html
+%%PORTDOCS%%%%DOCSDIR%%/structlibnet__802__1x__hdr.html
+%%EXAMPLESDIR%%/arp-new.c
+%%EXAMPLESDIR%%/arp.c
+%%EXAMPLESDIR%%/bgp4_hdr.c
+%%EXAMPLESDIR%%/bgp4_notification.c
+%%EXAMPLESDIR%%/bgp4_open.c
+%%EXAMPLESDIR%%/bgp4_update.c
+%%EXAMPLESDIR%%/cdp.c
+%%EXAMPLESDIR%%/dhcp_discover.c
+%%EXAMPLESDIR%%/dns.c
+%%EXAMPLESDIR%%/dot1x.c
+%%EXAMPLESDIR%%/fddi_tcp1.c
+%%EXAMPLESDIR%%/fddi_tcp2.c
+%%EXAMPLESDIR%%/get_addr.c
+%%EXAMPLESDIR%%/gre.c
+%%EXAMPLESDIR%%/icmp6_echoreq.c
+%%EXAMPLESDIR%%/icmp_echo_cq.c
+%%EXAMPLESDIR%%/icmp_redirect.c
+%%EXAMPLESDIR%%/icmp_timeexceed.c
+%%EXAMPLESDIR%%/icmp_timestamp.c
+%%EXAMPLESDIR%%/icmp_unreach.c
+%%EXAMPLESDIR%%/ieee.c
+%%EXAMPLESDIR%%/ip_link.c
+%%EXAMPLESDIR%%/ip_raw.c
+%%EXAMPLESDIR%%/isl.c
+%%EXAMPLESDIR%%/mpls.c
+%%EXAMPLESDIR%%/ntp.c
+%%EXAMPLESDIR%%/ospf_hello.c
+%%EXAMPLESDIR%%/ospf_lsa.c
+%%EXAMPLESDIR%%/ping_of_death.c
+%%EXAMPLESDIR%%/rpc_tcp.c
+%%EXAMPLESDIR%%/rpc_udp.c
+%%EXAMPLESDIR%%/sebek.c
+%%EXAMPLESDIR%%/smurf.c
+%%EXAMPLESDIR%%/stp.c
+%%EXAMPLESDIR%%/synflood.c
+%%EXAMPLESDIR%%/synflood6.c
+%%EXAMPLESDIR%%/synflood6_frag.c
+%%EXAMPLESDIR%%/tcp1.c
+%%EXAMPLESDIR%%/tcp2.c
+%%EXAMPLESDIR%%/tftp.c
+%%EXAMPLESDIR%%/tring_tcp1.c
+%%EXAMPLESDIR%%/tring_tcp2.c
+%%EXAMPLESDIR%%/udp1.c
+%%EXAMPLESDIR%%/udp2.c
+@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm include/libnet