aboutsummaryrefslogtreecommitdiff
path: root/net/libnetdude/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/libnetdude/Makefile')
-rw-r--r--net/libnetdude/Makefile18
1 files changed, 10 insertions, 8 deletions
diff --git a/net/libnetdude/Makefile b/net/libnetdude/Makefile
index 266597404255..ee9624d65638 100644
--- a/net/libnetdude/Makefile
+++ b/net/libnetdude/Makefile
@@ -3,29 +3,31 @@
PORTNAME= libnetdude
PORTVERSION= 0.12
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= SF/netdude/${PORTNAME}/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-COMMENT= A library for manipulating libpcap/tcpdump trace files
+COMMENT= Library for manipulating libpcap/tcpdump trace files
-LIB_DEPENDS= pcapnav.0:${PORTSDIR}/net/libpcapnav
+LIB_DEPENDS= libpcapnav.so:${PORTSDIR}/net/libpcapnav
-USE_AUTOTOOLS= libtool
+USES= libtool
GNU_CONFIGURE= yes
USE_GNOME= glib12
CONFIGURE_ARGS= --disable-gtk-doc --with-html-dir=${DOCSDIR}
USE_LDCONFIG= yes
+INSTALL_TARGET= install-strip
PLIST_SUB= PORTVERSION=${PORTVERSION}
+PORTDOCS= *
+
+OPTIONS_DEFINE= DOCS
post-patch:
@${REINPLACE_CMD} -e "s|netinet/if_fddi.h|net/fddi.h|g" \
- ${WRKSRC}/protocols/fddi/libnd_fddi.h
+ ${WRKSRC}/protocols/fddi/libnd_fddi.h
@${REINPLACE_CMD} -e 's|DOC_MODULE = libnetdude|DOC_MODULE =|' \
- ${WRKSRC}/docs/Makefile.in
-.if defined(NOPORTDOCS)
- @${REINPLACE_CMD} -e 's|docs||' ${WRKSRC}/Makefile.in
-.endif
+ ${WRKSRC}/docs/Makefile.in
.include <bsd.port.mk>