aboutsummaryrefslogtreecommitdiff
path: root/net/libosip/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/libosip/Makefile')
-rw-r--r--net/libosip/Makefile20
1 files changed, 12 insertions, 8 deletions
diff --git a/net/libosip/Makefile b/net/libosip/Makefile
index d1605dcc38e8..9c7a7e4ec042 100644
--- a/net/libosip/Makefile
+++ b/net/libosip/Makefile
@@ -7,24 +7,28 @@
#
PORTNAME= libosip
-PORTVERSION= 0.9.7
-PORTREVISION= 1
+PORTVERSION= 3.0.1
CATEGORIES= net
-MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITES= ${MASTER_SITE_GNU} \
+ http://www.antisip.com/download/
MASTER_SITE_SUBDIR= osip
+DISTNAME= ${PORTNAME}2-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= xride@FreeBSD.org
COMMENT= A low layer of SIP implementation
-DEPRECATED= distfile disappeared and this software is obsoleted by net/libosip2
-EXPIRATION_DATE= 2007-01-04
+CONFLICTS= libosip2-2*
+WRKSRC= ${WRKDIR}/${PORTNAME}2-${PORTVERSION}
+
+USE_GNOME= gnomehack gnometarget pkgconfig
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-debug --disable-trace
USE_AUTOTOOLS= libtool:15
USE_LDCONFIG= yes
-MAN1= osip.1
-
post-patch:
@${REINPLACE_CMD} -e "s|-pthread|${PTHREAD_LIBS}|g" ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e "/^SUBDIRS/s| help | |g" ${WRKSRC}/Makefile.in
.include <bsd.port.mk>