aboutsummaryrefslogtreecommitdiff
path: root/net/libtnl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/libtnl/Makefile')
-rw-r--r--net/libtnl/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/net/libtnl/Makefile b/net/libtnl/Makefile
index bb78ac4df78b..f775a7692b1b 100644
--- a/net/libtnl/Makefile
+++ b/net/libtnl/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= aaron@FreeBSD.org
COMMENT= A robust, secure, easy to use cross-platform C++ networking API
WRKSRC= ${WRKDIR}/tnl/tnl
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
ONLY_FOR_ARCHS= i386
post-extract:
@@ -25,4 +25,10 @@ post-extract:
pre-install:
${MKDIR} ${PREFIX}/include/tnl
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700042
+BROKEN= Does not compile with GCC 4.2
+.endif
+
+.include <bsd.port.post.mk>