aboutsummaryrefslogtreecommitdiff
path: root/net/licq-devel/files
diff options
context:
space:
mode:
Diffstat (limited to 'net/licq-devel/files')
-rw-r--r--net/licq-devel/files/patch-aa11
-rw-r--r--net/licq-devel/files/patch-ab31
-rw-r--r--net/licq-devel/files/patch-ac11
-rw-r--r--net/licq-devel/files/patch-ad48
-rw-r--r--net/licq-devel/files/patch-ae41
5 files changed, 0 insertions, 142 deletions
diff --git a/net/licq-devel/files/patch-aa b/net/licq-devel/files/patch-aa
deleted file mode 100644
index fd53298e4563..000000000000
--- a/net/licq-devel/files/patch-aa
+++ /dev/null
@@ -1,11 +0,0 @@
---- plugins/qt-gui/configure.in.orig Wed Aug 9 14:07:59 2000
-+++ plugins/qt-gui/configure.in Wed Aug 9 14:15:46 2000
-@@ -51,8 +51,6 @@
- LICQ_CHECK_X11HEADERS
-
- XSS_LIBS="no"
--AC_CHECK_X_LIB(Xext, XScreenSaverRegister,[XSS_LIBS=""],[], [-lX11 -lXext -lm])
--AC_CHECK_X_LIB(Xss, XScreenSaverRegister,[XSS_LIBS="-lXss"],[],[-lX11 -lXext -lm])
- if test \! "$XSS_LIBS" = "no"; then
- AC_CHECK_X_HEADER(X11/extensions/scrnsaver.h,[AC_DEFINE(USE_SCRNSAVER)])
- else
diff --git a/net/licq-devel/files/patch-ab b/net/licq-devel/files/patch-ab
deleted file mode 100644
index 852716c052a3..000000000000
--- a/net/licq-devel/files/patch-ab
+++ /dev/null
@@ -1,31 +0,0 @@
---- plugins/qt-gui/acinclude.m4.in.orig Sun Jun 18 06:20:57 2000
-+++ plugins/qt-gui/acinclude.m4.in Mon Jul 24 03:09:28 2000
-@@ -48,7 +48,7 @@
- fi
-
- for qt_dir in $qt_library_dirs; do
-- for qt_check_lib in $qt_dir/libqt.so.2; do
-+ for qt_check_lib in $qt_dir/libqt2.so.3; do
- if test -r $qt_check_lib; then
- ac_qt_libraries=$qt_dir
- break 2
-@@ -68,7 +68,7 @@
- else
- have_qt_lib="yes"
- dnl Check if we have the right lib
-- output=`eval "strings $ac_cv_lib_qtlib/libqt.so | grep -l QCString"`
-+ output=`eval "strings $ac_cv_lib_qtlib/libqt2.so | grep -l QCString"`
- if test -z "$output"; then
- AC_MSG_ERROR([
- The Qt lib directory "$ac_cv_lib_qtlib"
-@@ -185,8 +185,8 @@
-
- AC_PATH_PROG(
- MOC,
-- moc,
-- $QTDIR/bin/moc,
-+ moc2,
-+ $QTDIR/bin/moc2,
- $QTDIR/bin:/usr/lib/qt2/bin:/usr/bin:/usr/X11R6/bin:/usr/lib/qt/bin:/usr/local/qt/bin:$PATH
- )
- else
diff --git a/net/licq-devel/files/patch-ac b/net/licq-devel/files/patch-ac
deleted file mode 100644
index d24dbe10a567..000000000000
--- a/net/licq-devel/files/patch-ac
+++ /dev/null
@@ -1,11 +0,0 @@
---- plugins/qt-gui/src/Makefile.in.orig Tue Jul 11 18:54:27 2000
-+++ plugins/qt-gui/src/Makefile.in Mon Jul 24 03:12:25 2000
-@@ -119,7 +119,7 @@
-
- licq_qt_gui_la_LDFLAGS = $(X_LIBS) $(QT_LDFLAGS) $(KDE_LDFLAGS) -module -avoid-version -rpath $(libdir) -R$(QT_LIBDIR)
-
--licq_qt_gui_la_LIBADD = $(KDE_LIBS) -lqt $(X_PRE_LIBS) -lX11 -lXext $(XSS_LIBS) $(X_EXTRA_LIBS)
-+licq_qt_gui_la_LIBADD = $(KDE_LIBS) -lqt2 $(X_PRE_LIBS) -lX11 -lXext $(XSS_LIBS) $(X_EXTRA_LIBS)
-
-
- #>- METASOURCES = AUTO
diff --git a/net/licq-devel/files/patch-ad b/net/licq-devel/files/patch-ad
deleted file mode 100644
index 7bf734c85ce6..000000000000
--- a/net/licq-devel/files/patch-ad
+++ /dev/null
@@ -1,48 +0,0 @@
---- src/socket.cpp.orig Tue Jul 4 20:51:50 2000
-+++ src/socket.cpp Mon Jul 24 03:32:56 2000
-@@ -12,6 +12,7 @@
- #include <netdb.h>
- #include <fcntl.h>
- #include <unistd.h>
-+#include <osreldate.h>
-
- #ifndef MSG_DONTWAIT
- #define MSG_DONTWAIT 0
-@@ -288,7 +289,12 @@
- bool INetSocket::SetLocalAddress(bool bIp)
- {
- // Setup the local structure
-+
-+#if __FreeBSD_version < 400013
-+ int sizeofSockaddr = sizeof(struct sockaddr_in);
-+#else
- socklen_t sizeofSockaddr = sizeof(struct sockaddr_in);
-+#endif
- if (getsockname(m_nDescriptor, (struct sockaddr *)&m_sLocalAddr, &sizeofSockaddr) < 0)
- {
- m_nErrorType = SOCK_ERROR_errno;
-@@ -372,7 +378,11 @@
- m_sRemoteAddr.sin_family = AF_INET;
-
- // if connect fails then call CloseConnection to clean up before returning
-+#if __FreeBSD_version < 400013
-+ int sizeofSockaddr = sizeof(struct sockaddr);
-+#else
- socklen_t sizeofSockaddr = sizeof(struct sockaddr);
-+#endif
- if (connect(m_nDescriptor, (struct sockaddr *)&m_sRemoteAddr, sizeofSockaddr) < 0)
- {
- // errno has been set
-@@ -504,7 +514,11 @@
- *---------------------------------------------------------------------------*/
- void TCPSocket::RecvConnection(TCPSocket &newSocket)
- {
-- socklen_t sizeofSockaddr = sizeof(struct sockaddr_in);
-+#if __FreeBSD_version < 400013
-+ int sizeofSockaddr = sizeof(struct sockaddr_in);
-+#else
-+ socklen_t sizeofSockaddr = sizeof(struct sockaddr_in);
-+#endif
- newSocket.m_nDescriptor = accept(m_nDescriptor, (struct sockaddr *)&newSocket.m_sRemoteAddr, &sizeofSockaddr);
- newSocket.SetLocalAddress();
- }
diff --git a/net/licq-devel/files/patch-ae b/net/licq-devel/files/patch-ae
deleted file mode 100644
index ce5e40b135cc..000000000000
--- a/net/licq-devel/files/patch-ae
+++ /dev/null
@@ -1,41 +0,0 @@
---- plugins/qt-gui/aclocal.m4.orig Tue Jul 11 18:54:25 2000
-+++ plugins/qt-gui/aclocal.m4 Wed Aug 9 14:53:40 2000
-@@ -59,7 +59,7 @@
- fi
-
- for qt_dir in $qt_library_dirs; do
-- for qt_check_lib in $qt_dir/libqt.so.2; do
-+ for qt_check_lib in $qt_dir/libqt2.so.3; do
- if test -r $qt_check_lib; then
- ac_qt_libraries=$qt_dir
- break 2
-@@ -79,17 +79,12 @@
- else
- have_qt_lib="yes"
- dnl Check if we have the right lib
-- output=`eval "strings $ac_cv_lib_qtlib/libqt.so | grep -l QCString"`
-+ output=`eval "strings $ac_cv_lib_qtlib/libqt2.so | grep -l QCString"`
- if test -z "$output"; then
- AC_MSG_ERROR([
- The Qt lib directory "$ac_cv_lib_qtlib"
- found by configure doesn't contain a Qt 2.1.x library.
-
-- To overcome special features of the GNU ld (aka bugs), the
-- libqt.so file _needs_ to point to libqt.so.2 which needs
-- to point to a Qt 2.1 library.
-- (this is only needed during compiling and linking, not at runtime)
--
- Please check your installation.
-
- Use the --with-qt-libraries option if we found the wrong Qt lib.
-@@ -196,8 +191,8 @@
-
- AC_PATH_PROG(
- MOC,
-- moc,
-- $QTDIR/bin/moc,
-+ moc2,
-+ $QTDIR/bin/moc2,
- $QTDIR/bin:/usr/lib/qt2/bin:/usr/bin:/usr/X11R6/bin:/usr/lib/qt/bin:/usr/local/qt/bin:$PATH
- )
- else