aboutsummaryrefslogtreecommitdiff
path: root/net/linphone-base/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/linphone-base/Makefile')
-rw-r--r--net/linphone-base/Makefile22
1 files changed, 11 insertions, 11 deletions
diff --git a/net/linphone-base/Makefile b/net/linphone-base/Makefile
index faa920438fb7..9bfe403808c9 100644
--- a/net/linphone-base/Makefile
+++ b/net/linphone-base/Makefile
@@ -6,26 +6,26 @@
#
PORTNAME= linphone
-PORTVERSION= 0.11.0
-PORTREVISION= 2
+PORTVERSION= 0.12.0
PORTEPOCH= 1
CATEGORIES= net
-MASTER_SITES= http://simon.morlat.free.fr/download/${PORTVERSION}/source/
+MASTER_SITES= http://simon.morlat.free.fr/download/%SUBDIR%/
+MASTER_SITE_SUBDIR= ${PORTVERSION}/source
MAINTAINER= ports@FreeBSD.org
COMMENT= A web phone that supports SIP protocol
-LIB_DEPENDS= osip.9:${PORTSDIR}/net/libosip \
- ogg.4:${PORTSDIR}/audio/libogg
+LIB_DEPENDS= gsm.1:${PORTSDIR}/audio/gsm \
+ speex.2:${PORTSDIR}/audio/speex \
+ osip.9:${PORTSDIR}/net/libosip
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_LIBTOOL= yes
-LIBTOOLFILES= configure oRTP/configure speex/configure osipua/configure
-USE_GNOME= gnomehack gnomeprefix libgnomeui gnomepanel
-CONFIGURE_ARGS= --disable-ipv6
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+USE_GNOME= gnomehack gnomeprefix gnomepanel
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CONFIGURE_ARGS= --enable-platform-gnome-2 --disable-ipv6
MAN1= linphone.1 linphonec.1 sipomatic.1