aboutsummaryrefslogtreecommitdiff
path: root/net/mldonkey-devel
diff options
context:
space:
mode:
Diffstat (limited to 'net/mldonkey-devel')
-rw-r--r--net/mldonkey-devel/Makefile51
-rw-r--r--net/mldonkey-devel/distinfo2
-rw-r--r--net/mldonkey-devel/files/kill_mldonkey51
-rw-r--r--net/mldonkey-devel/files/wrapper.sh18
-rw-r--r--net/mldonkey-devel/pkg-descr16
-rw-r--r--net/mldonkey-devel/pkg-message15
-rw-r--r--net/mldonkey-devel/pkg-plist12
7 files changed, 0 insertions, 165 deletions
diff --git a/net/mldonkey-devel/Makefile b/net/mldonkey-devel/Makefile
deleted file mode 100644
index 63449034c786..000000000000
--- a/net/mldonkey-devel/Makefile
+++ /dev/null
@@ -1,51 +0,0 @@
-# New ports collection makefile for: mldonkey
-# Date created: 21 August 2002
-# Whom: Holger Lamm <holger@e-gitt.net>
-#
-# $FreeBSD$
-#
-
-PORTNAME= mldonkey
-PORTVERSION= 2.04.r1
-CATEGORIES= net
-MASTER_SITES= http://savannah.nongnu.org/download/mldonkey/release-2.04rc1/contributed/holger/
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/.r/rc/}-0.shared.${ARCH}-${OPSYS}-hl
-
-MAINTAINER= holger@e-gitt.net
-COMMENT= A OCAML client for eDonkey and Overnet peer-to-peer networks (core)
-
-ONLY_FOR_ARCHS= alpha i386
-USE_BZIP2= yes
-NO_BUILD= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}-distrib-${PORTVERSION:S/.r/rc/}-0
-
-DIRNAME= ${HOME}/.mldonkey
-
-DOCFILES= AUTHORS BUGS ChangeLog Developers.txt FAQ.html \
- Readme.txt TODO ed2k_links.txt
-
-post-patch:
- @${SED} -e "s|%%PREFIX%%|${PREFIX}|" ${FILESDIR}/wrapper.sh > \
- ${WRKDIR}/wrapper.sh
-
-do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/mldonkey ${PREFIX}/bin/mldonkey-real
- @${INSTALL_SCRIPT} ${FILESDIR}/kill_mldonkey ${PREFIX}/bin
- @${INSTALL_SCRIPT} ${WRKDIR}/wrapper.sh ${PREFIX}/bin/mldonkey
-.ifndef(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for file in ${DOCFILES}
- @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
-.endfor
-.endif
-
-post-install:
- @${SED} -e 's|/usr/local/|${PREFIX}/|' ${PKGMESSAGE}
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500000
-LIB_DEPENDS+= c_r.4:${PORTSDIR}/misc/compat4x
-.endif
-
-.include <bsd.port.post.mk>
diff --git a/net/mldonkey-devel/distinfo b/net/mldonkey-devel/distinfo
deleted file mode 100644
index 4f411fb1a72f..000000000000
--- a/net/mldonkey-devel/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 (mldonkey-2.04rc1-0.shared.alpha-FreeBSD-hl.tar.bz2) = 41dcb32d1d982de203388d83b18ff3c1
-MD5 (mldonkey-2.04rc1-0.shared.i386-FreeBSD-hl.tar.bz2) = af85d3aed07256e5c3568de2a25d25fb
diff --git a/net/mldonkey-devel/files/kill_mldonkey b/net/mldonkey-devel/files/kill_mldonkey
deleted file mode 100644
index 17a7de100aad..000000000000
--- a/net/mldonkey-devel/files/kill_mldonkey
+++ /dev/null
@@ -1,51 +0,0 @@
-#
-# Copyright (c) 2003
-# Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
-# Holger Lamm <holger@e-gitt.net>
-# All rights reserved.
-#
-# Redistribution and use in source and binary forms, with or without
-# modification, are permitted provided that the following conditions
-# are met:
-# 1. Redistributions of source code must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-# 2. Redistributions in binary form must reproduce the above copyright
-# notice, this list of conditions and the following disclaimer in the
-# documentation and/or other materials provided with the distribution.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR AND CONTRIBUTORS ``AS IS'' AND
-# ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
-# IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
-# ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE
-# FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
-# DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
-# OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
-# HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
-# LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
-# OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
-# SUCH DAMAGE.
-#
-
-#!/bin/sh
-
-#
-# Add Username and password here
-# like this:
-#
-HTTPUSER="you"
-HTTPPASS="yourpassword"
-
-# Add location and port of mldonkey core
-HTTPURL="127.0.0.1:4080"
-
-# internal configuration
-HTTP_COMMAND="/usr/bin/fetch"
-HTTP_COMMAND_ARGS="-1 -q -s"
-
-if [ -n "${HTTPUSER}" -a -n "${HTTPPASS}" ]
-then
- export HTTP_AUTH=basic:*:${HTTPUSER}:${HTTPPASS}
-fi
-
-${HTTP_COMMAND} ${HTTP_COMMAND_ARGS} "http://${HTTPURL}/submit?q=kill"
-
diff --git a/net/mldonkey-devel/files/wrapper.sh b/net/mldonkey-devel/files/wrapper.sh
deleted file mode 100644
index c25fd62bc133..000000000000
--- a/net/mldonkey-devel/files/wrapper.sh
+++ /dev/null
@@ -1,18 +0,0 @@
-#!/bin/sh
-
-PREFIX="%%PREFIX%%/bin"
-PROGRAM="${0}"
-DIRNAME=${HOME}/.mldonkey
-
-if [ ! -d ${DIRNAME} ]
-then
- mkdir -p ${DIRNAME}
-fi
-
-echo " ${*} " | grep " \-createdironly " ||
-{
- cd ${DIRNAME} &&
- echo Running under ${DIRNAME} &&
- exec ${PREFIX}/${PROGRAM##*/}-real "${@}" ||
- echo PROBLEM. Cannot create directory ${DIRNAME}, make sure you have the proper permissions to create it and try again
-}
diff --git a/net/mldonkey-devel/pkg-descr b/net/mldonkey-devel/pkg-descr
deleted file mode 100644
index a7cf4a8312ae..000000000000
--- a/net/mldonkey-devel/pkg-descr
+++ /dev/null
@@ -1,16 +0,0 @@
-mldonkey is a OCAML/GTK client for both eDonkey and Overnet
-peer-to-peer networks.
-(see http://www.edonkey2000.com/ and the 'edonkey' ports)
-(see http://www.overnet.com/)
-
-It is separated into a core with telnet and web interfaces, and
-brings a GTK GUI (see the separate mldonkey-gui port).
-
-Other features over the original eDonkey client are:
-- better stability
-- faster operation
-- much better control
-- saves its current state, checksums and known peers
- (instead of starting from scratch every time)
-
-WWW: http://www.freesoftware.fsf.org/mldonkey/
diff --git a/net/mldonkey-devel/pkg-message b/net/mldonkey-devel/pkg-message
deleted file mode 100644
index 8f51f832d1f3..000000000000
--- a/net/mldonkey-devel/pkg-message
+++ /dev/null
@@ -1,15 +0,0 @@
- ATTENTIONATTENTION:
-
-- If you want to know how to use mldonkey, read "Readme.txt" or
- "FAQ.html" in the port docs (/usr/local/share/doc/mldonkey)
-
-- It is not a bad idea to install mplayer. You will be able
- to preview half-downloaded files (if you have the beginning).
-
-- Please make sure that you read
- /usr/local/share/doc/mldonkey/Readme.txt.
- It contains important information about how to run mldonkey.
-
-- You can import the downloads you started with eDonkey
- (try "import /home/directory/path/.edonkey2000-core"
- on the console), but you can NOT go back!
diff --git a/net/mldonkey-devel/pkg-plist b/net/mldonkey-devel/pkg-plist
deleted file mode 100644
index 2fc8284978db..000000000000
--- a/net/mldonkey-devel/pkg-plist
+++ /dev/null
@@ -1,12 +0,0 @@
-bin/kill_mldonkey
-bin/mldonkey
-bin/mldonkey-real
-%%PORTDOCS%%share/doc/mldonkey/AUTHORS
-%%PORTDOCS%%share/doc/mldonkey/BUGS
-%%PORTDOCS%%share/doc/mldonkey/ChangeLog
-%%PORTDOCS%%share/doc/mldonkey/Developers.txt
-%%PORTDOCS%%share/doc/mldonkey/FAQ.html
-%%PORTDOCS%%share/doc/mldonkey/Readme.txt
-%%PORTDOCS%%share/doc/mldonkey/TODO
-%%PORTDOCS%%share/doc/mldonkey/ed2k_links.txt
-%%PORTDOCS%%@dirrm share/doc/mldonkey