aboutsummaryrefslogtreecommitdiff
path: root/net/mopd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/mopd/Makefile')
-rw-r--r--net/mopd/Makefile15
1 files changed, 10 insertions, 5 deletions
diff --git a/net/mopd/Makefile b/net/mopd/Makefile
index feaa393ca73a..90468142f370 100644
--- a/net/mopd/Makefile
+++ b/net/mopd/Makefile
@@ -7,10 +7,6 @@ PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= obrien
-.if !defined(NOPORTDOCS)
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
- VAX-netboot-HOWTO VS3100-console-cmds.txt
-.endif
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= obrien@FreeBSD.org
@@ -18,11 +14,20 @@ COMMENT= MOP Loader Daemon for netbooting DEC machines
MAKE_ENV= BINDIR=${PREFIX}/sbin MANDIR=${PREFIX}/man/man NO_MANCOMPRESS=true
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS} || make(makesum)
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
+ VAX-netboot-HOWTO VS3100-console-cmds.txt
+.endif
+
do-configure:
@${REINPLACE_CMD} -e 's/MAN=/MAN8=/' ${WRKSRC}/mopd/Makefile
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
@${INSTALL_MAN} ${DISTDIR}/VAX-netboot-HOWTO \
${DISTDIR}/VS3100-console-cmds.txt ${STAGEDIR}${DOCSDIR}