aboutsummaryrefslogtreecommitdiff
path: root/net/mopd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/mopd/Makefile')
-rw-r--r--net/mopd/Makefile17
1 files changed, 16 insertions, 1 deletions
diff --git a/net/mopd/Makefile b/net/mopd/Makefile
index a4f138e7c3f4..5090572c9687 100644
--- a/net/mopd/Makefile
+++ b/net/mopd/Makefile
@@ -9,10 +9,18 @@
DISTNAME= mopd-2.5.3
CATEGORIES= net
-MASTER_SITES= ftp://ftp.stacken.kth.se/pub/OS/NetBSD/mopd/
+MASTER_SITES= ftp://ftp.stacken.kth.se/pub/OS/NetBSD/mopd/ \
+ http://world.std.com/~bdc/projects/vaxen/netboot/ \
+ http://world.std.com/~bdc/projects/vaxen/ \
+ http://world.std.com/~bdc/projects/vaxen/docs/
+.if !defined(NOPORTDOCS)
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
+ VAX-netboot-HOWTO VS3100-console-cmds.txt
+.endif
MAINTAINER= obrien@FreeBSD.org
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
# MANDIR is concetenated to DESTDIR which all forms the man install dir...
MAKE_ENV= DESTDIR=${PREFIX} MANDIR=/man/man NOMANCOMPRESS=true
MAN1= mopprobe.1 moptrace.1 mopchk.1 mopa.out.1
@@ -22,4 +30,11 @@ do-configure:
@${PERL} -pi.orig -e 's:/usr/sbin:/sbin:' ${WRKSRC}/Makefile.inc
@${PERL} -pi.orig -e 's/MAN=/MAN8=/' ${WRKSRC}/mopd/Makefile
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/mopd
+ @${INSTALL_MAN} ${DISTDIR}/VAX-netboot-HOWTO \
+ ${DISTDIR}/VS3100-console-cmds.txt ${PREFIX}/share/doc/mopd
+.endif
+
.include <bsd.port.mk>