aboutsummaryrefslogtreecommitdiff
path: root/net/mosquitto/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/mosquitto/Makefile')
-rw-r--r--net/mosquitto/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/net/mosquitto/Makefile b/net/mosquitto/Makefile
index a78e144b0874..a476e7c0fdbd 100644
--- a/net/mosquitto/Makefile
+++ b/net/mosquitto/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= mosquitto
-PORTVERSION= 1.4.4
-PORTREVISION= 1
+PORTVERSION= 1.4.9
CATEGORIES= net
MASTER_SITES= http://mosquitto.org/files/source/
@@ -15,7 +14,7 @@ LICENSE= BSD3CLAUSE
LIB_DEPENDS= libcares.so:dns/c-ares
BUILD_DEPENDS= xsltproc:textproc/libxslt
-USES= cmake python:2
+USES= cmake ssl
NOCONFIGURE= yes
USE_RC_SUBR= mosquitto
USE_LDCONFIG= yes
@@ -23,6 +22,12 @@ PLIST_SUB= PORTVERSION=${PORTVERSION}
USERS= nobody
+OPTIONS_DEFINE= WS
+
+WS_DESC= MQTT over Websockets support
+WS_LIB_DEPENDS= libwebsockets.so:net/libwebsockets
+WS_CMAKE_ON= -DWITH_WEBSOCKETS=ON
+
post-patch:
# do not run ldconfig in stage dir
${REINPLACE_CMD} -e '/ldconfig/d' ${WRKSRC}/src/CMakeLists.txt \