aboutsummaryrefslogtreecommitdiff
path: root/net/mugshot/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/mugshot/Makefile')
-rw-r--r--net/mugshot/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/net/mugshot/Makefile b/net/mugshot/Makefile
index b5c58ca6c12a..35395f2e22f7 100644
--- a/net/mugshot/Makefile
+++ b/net/mugshot/Makefile
@@ -24,7 +24,7 @@ BUILD_DEPENDS= ${PKGCONFIG_LOCAL_BASE}/dbus-1.pc:${PORTSDIR}/devel/dbus:install
${LOCALBASE}/include/firefox/caps/nsIScriptSecurityManager.h:${PORTSDIR}/www/firefox:install \
${LOCALBASE}/lib/libpcre.a:${PORTSDIR}/devel/pcre:install \
${LOCALBASE}/lib/firefox/xpidl:${PORTSDIR}/www/firefox:install \
- ${X11BASE}/include/X11/extensions/scrnsaver.h:${PORTSDIR}/x11/xorg-libraries:install \
+ ${LOCALBASE}/include/X11/extensions/scrnsaver.h:${PORTSDIR}/x11/xorg-libraries:install \
dbus>=1.0.2:${PORTSDIR}/devel/dbus:install
USE_GNOME= gnomehack gconf2 glib20 gtk20 pango gnomevfs2 gnomedesktop
@@ -38,7 +38,7 @@ USE_LDCONFIG= yes
LDCONFIG_DIRS= %%PREFIX%%/lib/mugshot/firefox/components
PKGCONFIG_LOCAL_BASE= ${LOCALBASE}/libdata/pkgconfig
-PKGCONFIG_X11_BASE= ${X11BASE}/libdata/pkgconfig
+PKGCONFIG_X11_BASE= ${LOCALBASE}/libdata/pkgconfig
mugshot_INSTALL_cmd= install
@@ -48,8 +48,8 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= "--with-gecko-idl=${FIREFOX_IDL_PATH}" \
"--with-gecko-headers=${LOCALBASE}/include/firefox" \
"--with-xpidl=${LOCALBASE}/lib/firefox/xpidl" \
- "--x-includes=${X11BASE}/include" \
- "--x-libraries=${X11BASE}/lib"
+ "--x-includes=${LOCALBASE}/include" \
+ "--x-libraries=${LOCALBASE}/lib"
FIREFOX_IDL_PATH!=${SH} -c 'for i in ${LOCALBASE}/share/idl/firefox-*; do [ -f $$i/nsIURI.idl ] && ${ECHO} $$i && break; done; exit 0;'
BUILD_DEPENDS+=${FIREFOX_IDL_PATH}/nsIURI.idl:${PORTSDIR}/www/firefox:install