aboutsummaryrefslogtreecommitdiff
path: root/net/netatalk-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/netatalk-devel/Makefile')
-rw-r--r--net/netatalk-devel/Makefile48
1 files changed, 34 insertions, 14 deletions
diff --git a/net/netatalk-devel/Makefile b/net/netatalk-devel/Makefile
index 1215201f32fb..4482ae110581 100644
--- a/net/netatalk-devel/Makefile
+++ b/net/netatalk-devel/Makefile
@@ -6,40 +6,54 @@
#
PORTNAME= netatalk
-PORTVERSION= 1.5p6
-PORTREVISION= 1
+PORTVERSION= 1.5p7
CATEGORIES= net print
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= netatalk
-DISTNAME= netatalk-1.5pre6
+DISTNAME= netatalk-1.5pre7
MAINTAINER= marcus@marcuscom.com
+.if defined(WITH_CNID)
+LIB_DEPENDS= db3.2:${PORTSDIR}/databases/db3
+.endif
.if !exists(/usr/include/tcpd.h)
-LIB_DEPENDS= wrap.7:${PORTSDIR}/security/tcp_wrapper
+LIB_DEPENDS+= wrap.7:${PORTSDIR}/security/tcp_wrapper
.endif
CONFIGURE_ARGS+= --with-tcp-wrappers \
- --enable-lastdid
-# CONFIGURE_ARGS+= --disable-admin-group
-# CONFIGURE_ARGS+= --disable-ddp
-# CONFIGURE_ARGS+= --with-shadow
-.if defined(NETATALK_WITH_PAM)
-CONFIGURE_ARGS+= --with-pam # broken
+ --with-pkgconfdir=${PREFIX}/etc
+.if defined(WITH_PAM)
PLIST_SUB+= NETATALKPAM=""
.else
+CONFIGURE_ARGS+= --without-pam
PLIST_SUB+= NETATALKPAM="@comment "
.endif
-GNU_CONFIGURE= yes
+.if defined(WITH_CNID)
+# Configure EXPERIMENTAL CNID DID support. This is an attmept to make
+# DIDs more persistent by using a Berkeley database to store the DID values.
+# This should hopefully allow aliases to work between restarts of afpd.
+# This has been tested on MacOS 9.2.1. I have not gotten working on OS X.
+CONFIGURE_ARGS+= --enable-cnid-db \
+ --with-db3=/usr/local
+.else
+# This method of DID calculation is not persistent, but has been tested to
+# work with MacOS X (10.0.4) as well as MacOS 7-9.2.1.
+CONFIGURE_ARGS+= --with-did=last
+.endif
+USE_AUTOCONF= yes
+USE_LIBTOOL= yes
+LIBTOOLFILES= configure
USE_GMAKE= yes
FILES= AppleVolumes.default AppleVolumes.system afpd.conf \
- atalkd.conf netatalk.conf netatalk.pamd papd.conf
+ atalkd.conf papd.conf
LINKS= unbin unhex unsingle hqx2bin single2bin macbinary \
binheader nadheader
MAN1= achfile.1 aecho.1 afile.1 afppasswd.1 getzones.1 \
megatron.1 nbp.1 pap.1 psorder.1 hqx2bin.1 macbinary.1 \
nbplkup.1 nbprgstr.1 nbpunrgstr.1 papstatus.1 \
- single2bin.1 unbin.1 unhex.1 unsingle.1
+ single2bin.1 unbin.1 unhex.1 unsingle.1 acleandir.1 \
+ netatalk-config.1 timeout.1
MAN3= atalk_aton.3 nbp_name.3
MAN4= atalk.4
MAN5= AppleVolumes.default.5 afpd.conf.5 atalkd.conf.5 \
@@ -51,7 +65,9 @@ post-extract:
> ${WRKSRC}/netatalk.sh
post-install:
- @${RM} -f ${PREFIX}/bin/nu ${PREFIX}/bin/lp2pap.sh
+ @${RM} -f ${PREFIX}/bin/nu ${PREFIX}/bin/lp2pap.sh \
+ ${PREFIX}/etc/netatalk.pamd.dist ${PREFIX}/bin/test_parse_mtab \
+ ${PREFIX}/bin/afpd-mtab.pl ${PREFIX}/etc/netatalk.conf.dist
${INSTALL_SCRIPT} ${WRKSRC}/netatalk.sh ${PREFIX}/etc/rc.d/netatalk.sh
${INSTALL_SCRIPT} ${WRKSRC}/contrib/macusers/macusers \
${PREFIX}/bin/macusers
@@ -63,4 +79,8 @@ post-install:
( cd ${PREFIX}/bin && ${LN} -sf megatron ${i} )
.endfor
+.if defined(WITH_PAM)
+ @${CAT} ${PKGMESSAGE}
+.endif
+
.include <bsd.port.mk>