aboutsummaryrefslogtreecommitdiff
path: root/net/netselect/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/netselect/Makefile')
-rw-r--r--net/netselect/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/net/netselect/Makefile b/net/netselect/Makefile
new file mode 100644
index 000000000000..7df0c9be64f4
--- /dev/null
+++ b/net/netselect/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: netselect
+# Date created: 15 July 2006
+# Whom: Timothy Redaelli <drizzt@gufi.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= netselect
+PORTVERSION= 0.3
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_GENTOO} \
+ http://www.worldvisions.ca/~apenwarr/netselect/
+MASTER_SITE_SUBDIR= distfiles
+
+MAINTAINER= drizzt@gufi.org
+COMMENT= Ultrafast implementation of ping
+
+PLIST_FILES= bin/${PORTNAME}
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+OPTIONS= SUID "Install with the sticky bit (mode 4110)" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_SUID)
+BINMODE= 4110
+.else
+BINMODE= 0100
+.endif
+
+do-build:
+ ${CC} ${CFLAGS} -o ${WRKSRC}/${PORTNAME} ${WRKSRC}/${PORTNAME}.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.post.mk>