aboutsummaryrefslogtreecommitdiff
path: root/net/ng_netflow/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/ng_netflow/Makefile')
-rw-r--r--net/ng_netflow/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/net/ng_netflow/Makefile b/net/ng_netflow/Makefile
new file mode 100644
index 000000000000..7d78a187128b
--- /dev/null
+++ b/net/ng_netflow/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: ng_netflow
+# Date Created: Feb 17, 2003
+# Whom: Gleb Smirnoff <glebius@cell.sick.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ng_netflow
+PORTVERSION= 0.2.1
+CATEGORIES= net
+MASTER_SITES= http://cell.sick.ru/~glebius/ \
+ ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ng-netflow
+
+MAINTAINER= glebius@cell.sick.ru
+COMMENT= Netgraph node implementing Cisco (c) netflow
+
+NO_PACKAGE= Should be in sync with the kernel to work correctly
+
+PLIST_SUB= KMODDIR=${KMODDIR}
+
+MAN4= ng_netflow.4
+MAN8= flowctl.8
+MANCOMPRESSED= yes
+
+.include <bsd.port.pre.mk>
+
+pre-fetch:
+
+.if !exists(${SRC_BASE}/sys/Makefile)
+ IGNORE= "This port requires kernel sources"
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>