aboutsummaryrefslogtreecommitdiff
path: root/net/nmsg/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/nmsg/Makefile')
-rw-r--r--net/nmsg/Makefile58
1 files changed, 30 insertions, 28 deletions
diff --git a/net/nmsg/Makefile b/net/nmsg/Makefile
index 2a1043e7df0b..aa1a8dae80f1 100644
--- a/net/nmsg/Makefile
+++ b/net/nmsg/Makefile
@@ -5,27 +5,42 @@ PORTVERSION= 0.9.1
PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= https://dl.farsightsecurity.com/dist/nmsg/ \
- http://dl.farsightsecurity.com/dist/nmsg/
+ LOCAL/truckman/farsight
MAINTAINER= truckman@FreeBSD.org
COMMENT= Network message encapsulation system
LICENSE= APACHE20
-OPTIONS_DEFINE= DOCS EXAMPLES
-OPTIONS_SUB= yes
-
-.include <bsd.port.options.mk>
-
-LIB_DEPENDS+= libprotobuf-c.so:${PORTSDIR}/devel/protobuf-c \
+LIB_DEPENDS= libprotobuf-c.so:${PORTSDIR}/devel/protobuf-c \
libxs.so:${PORTSDIR}/devel/libxs \
libwdns.so:${PORTSDIR}/dns/wdns
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+USES= gmake libtool pathfix pkgconfig
+CONFIGURE_ARGS= --with-pkgconfigdir='$${exec_prefix}/libdata/pkgconfig'
+INSTALL_TARGET= install-strip
+
+PORTDOCS= *
+
+# The DOXYGEN option is best effort.
+# If doxygen is installed, it will get used if the option is set to NO.
+OPTIONS_DEFINE= DOXYGEN EXAMPLES MANPAGES
+OPTIONS_DEFAULT= DOXYGEN EXAMPLES MANPAGES
+OPTIONS_SUB= yes
+
+ALL_TARGET= all
+DOXYGEN_BUILD_DEPENDS= doxygen:${PORTSDIR}/devel/doxygen
+DOXYGEN_ALL_TARGET= html-local
DOCBOOK_XML= ${LOCALBASE}/share/xml/docbook/4.2
DOCBOOK_XSL_NS= ${LOCALBASE}/share/doc/docbook-xsl-ns/html/docbook.css.source.html
-BUILD_DEPENDS+= xsltproc:${PORTSDIR}/textproc/libxslt \
- ${DOCBOOK_XML}:${PORTSDIR}/textproc/docbook-xml \
- ${DOCBOOK_XSL_NS}:${PORTSDIR}/textproc/docbook-xsl-ns
+MANPAGES_BUILD_DEPENDS= xsltproc:${PORTSDIR}/textproc/libxslt \
+ ${DOCBOOK_XML}:${PORTSDIR}/textproc/docbook-xml \
+ ${DOCBOOK_XSL_NS}:${PORTSDIR}/textproc/docbook-xsl-ns
+MANPAGES_CONFIGURE_WITH= xsltproc
+
+.include <bsd.port.options.mk>
# The version of binutils in base does not understand the crc32
# instructions used in this code on amd64. Use gcc from ports
@@ -34,28 +49,15 @@ BUILD_DEPENDS+= xsltproc:${PORTSDIR}/textproc/libxslt \
USE_GCC= yes
.endif
-ALL_TARGET= all
-.if ${PORT_OPTIONS:MDOCS}
-BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen
-ALL_TARGET+= html-local
-.endif
-
-GNU_CONFIGURE= yes
-USE_LDCONFIG= yes
-USES= gmake libtool pathfix pkgconfig
-CONFIGURE_ARGS+= --with-pkgconfigdir='$${exec_prefix}/libdata/pkgconfig'
-
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libnmsg.so.6.0.0
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/nmsg/nmsg_msg9_base.so
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${STAGEDIR}${DOCSDIR}/html
- ${INSTALL_DATA} ${WRKSRC}/doc/doxygen/html/* ${STAGEDIR}${DOCSDIR}/html
+.if ${PORT_OPTIONS:MDOXYGEN}
+ (cd ${WRKSRC}/doc/doxygen && \
+ ${COPYTREE_SHARE} html ${STAGEDIR}${DOCSDIR})
.endif
.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/examples/*.c ${STAGEDIR}${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/examples/*.py ${STAGEDIR}${EXAMPLESDIR}
+ (cd ${WRKSRC}/examples && \
+ ${INSTALL_DATA} *.c *.py ${STAGEDIR}${EXAMPLESDIR})
.endif
.include <bsd.port.mk>