aboutsummaryrefslogtreecommitdiff
path: root/net/ntop/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/ntop/Makefile')
-rw-r--r--net/ntop/Makefile86
1 files changed, 40 insertions, 46 deletions
diff --git a/net/ntop/Makefile b/net/ntop/Makefile
index 844d9aa5a426..78b61ce75197 100644
--- a/net/ntop/Makefile
+++ b/net/ntop/Makefile
@@ -6,77 +6,71 @@
#
PORTNAME= ntop
-PORTVERSION= 2.0.99.r2
-PORTREVISION= 2
+PORTVERSION= 2.2
+PORTREVISION= 0
CATEGORIES= net
-MASTER_SITES= http://luca.ntop.org/ \
- ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= ${PORTNAME}-${PORTVERSION:S|.r|-rc|}
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Network monitoring tool with command line and web interfaces
-# Besides the required dependencies listed here, this port can optionally
-# make use of sysutils/lsof and security/nmap if installed.
BUILD_DEPENDS= ${LOCALBASE}/lib/libgdc.a:${PORTSDIR}/graphics/gdchart
-RUN_DEPENDS= ${LOCALBASE}/lib/libgdc.a:${PORTSDIR}/graphics/gdchart
-LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm
+LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
-# ntop will store its runtime database files in ${DBDIR}/ntop/
-DBDIR?= /var/db
+.if !defined(BATCH) && !defined(PACKAGE_BUILDING)
+IS_INTERACTIVE= yes
+.endif
-# The default startup script in ${LOCALBASE}/etc/rc.d will invoke
-# with a flag to force it to log to ${LOGDIR}
-LOGDIR?= /var/log
+DBDIR?= /var/db
-WRKSRC= ${WRKDIR}/RC2/${PORTNAME}
-USE_AUTOMAKE= yes
+WRKSRC= ${WRKDIR}/${DISTNAME}/${PORTNAME}
USE_GMAKE= yes
+USE_REINPLACE= yes
+USE_OPENSSL= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
PLIST_SUB+= DBDIR=${DBDIR}
-PKGMESSAGE= ${WRKDIR}/pkg-message
+CONFIGURE_ENV= LIBS="-lcrypto -L${LOCALBASE}/lib -lgnugetopt"
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --localstatedir=${DBDIR} \
- --with-gdbm-root=${LOCALBASE} \
+ --with-ossl-root=${OPENSSLBASE} \
--with-gdchart-root=${LOCALBASE}
+SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
+ TOUCH="${TOUCH}" \
+ MKDIR="${MKDIR}" \
+ CAT="${CAT}" \
+ OPTIONS="${OPTIONS}" \
+ REALCURDIR="${.CURDIR}"
-.if !defined(WITHOUT_TCPWRAP)
-CONFIGURE_ARGS+= --enable-tcpwrap
-.endif
-
-.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 400014
-LIB_DEPENDS+= ssl.3:${PORTSDIR}/security/openssl
-CONFIGURE_ARGS+= --with-ossl-root=${LOCALBASE}
-.endif
-
-MAN1= intop.1
MAN8= ntop.8
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile"
-.endif
+.include <bsd.port.pre.mk>
-# Remove included dependencies as a precaution against polluting the
-# configuration. Not strictly necessary.
-pre-configure:
- @ ${RM} -rf ${WRKDIR}/RC2/gdchart*
+pre-fetch:
+ @${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/configure.sh
-post-configure:
- @ ${SED} -e 's#%%LOCALBASE%%#${LOCALBASE}#g' \
- pkg-message > ${PKGMESSAGE}
+post-patch:
+ @${REINPLACE_CMD} -e "s,-lgdchart,-lgdc,g" \
+ -e "s,-lglib,-lglib12,g" ${WRKSRC}/configure
post-install:
- @ ${MKDIR} ${DBDIR}/ntop
- @ ${MKDIR} ${PREFIX}/etc/rc.d
- @ ${SED} -e "s#%%PREFIX%%#${PREFIX}#g" \
- -e "s#%%LOGDIR%%#${LOGDIR}#g" ${FILESDIR}/ntop.sh > \
- ${WRKDIR}/ntop.sh
- @ ${INSTALL_DATA} ${WRKDIR}/ntop.sh ${PREFIX}/etc/rc.d
+ @${MKDIR} ${DBDIR}/ntop
+ @${MKDIR} ${PREFIX}/etc/rc.d
+ @${SED} -e "s#%%PREFIX%%#${PREFIX}#g" \
+ -e "s#%%LOGDIR%%#${LOGDIR}#g" ${FILESDIR}/ntop.sh > \
+ ${WRKDIR}/ntop.sh
+ @${INSTALL_DATA} ${WRKDIR}/ntop.sh ${PREFIX}/etc/rc.d
.if !defined(BATCH)
- @ ${CAT} ${PKGMESSAGE}
+ @${SED} "s,%%LOCALBASE%%,${LOCALBASE},g" < ${PKGMESSAGE}
+.endif
+
+post-clean:
+ @${RM} -f ${WRKDIRPREFIX}${.CURDIR}/Makefile.inc
+
+.if exists(${WRKDIRPREFIX}${.CURDIR}/Makefile.inc)
+.include "${WRKDIRPREFIX}${.CURDIR}/Makefile.inc"
.endif
.include <bsd.port.post.mk>