aboutsummaryrefslogtreecommitdiff
path: root/net/online-desktop
diff options
context:
space:
mode:
Diffstat (limited to 'net/online-desktop')
-rw-r--r--net/online-desktop/Makefile14
-rw-r--r--net/online-desktop/distinfo6
-rw-r--r--net/online-desktop/pkg-plist40
3 files changed, 39 insertions, 21 deletions
diff --git a/net/online-desktop/Makefile b/net/online-desktop/Makefile
index 9241818a3d56..637d259ace89 100644
--- a/net/online-desktop/Makefile
+++ b/net/online-desktop/Makefile
@@ -6,9 +6,8 @@
#
PORTNAME= online-desktop
-PORTVERSION= 0.2.28
-PORTREVISION= 2
-CATEGORIES= net
+PORTVERSION= 0.2.29
+CATEGORIES= net gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
@@ -19,14 +18,17 @@ BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/dbus-1.pc:${PORTSDIR}/devel/dbus \
${LOCALBASE}/libdata/pkgconfig/dbus-glib-1.pc:${PORTSDIR}/devel/dbus-glib \
${LOCALBASE}/libdata/pkgconfig/nspr.pc:${PORTSDIR}/devel/nspr \
${LOCALBASE}/libdata/pkgconfig/nss.pc:${PORTSDIR}/security/nss \
- ${LOCALBASE}/libdata/pkgconfig/purple.pc:${PORTSDIR}/net-im/libpurple
+ ${LOCALBASE}/libdata/pkgconfig/purple.pc:${PORTSDIR}/net-im/libpurple \
+ ${LOCALBASE}/libdata/pkgconfig/pidgin.pc:${PORTSDIR}/net-im/pidgin
LIB_DEPENDS= dbus-1.3:${PORTSDIR}/devel/dbus \
dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
nspr4.1:${PORTSDIR}/devel/nspr \
nss3.1:${PORTSDIR}/security/nss \
purple.4:${PORTSDIR}/net-im/libpurple
RUN_DEPENDS= ${LOCALBASE}/libexec/desktop-data-engine:${PORTSDIR}/net/desktop-data-model \
- ${LOCALBASE}/bin/bigboard:${PORTSDIR}/misc/bigboard
+ ${LOCALBASE}/bin/bigboard:${PORTSDIR}/misc/bigboard \
+ ${LOCALBASE}/bin/purple-remote:${PORTSDIR}/net-im/libpurple \
+ ${LOCALBASE}/bin/pidgin:${PORTSDIR}/net-im/pidgin
USE_BZIP2= yes
USE_GNOME= glib20 gconf2
@@ -35,6 +37,8 @@ USE_GETTEXT= yes
GNU_CONFIGURE= yes
USE_PYTHON= 2.5+
GCONF_SCHEMAS= online-desktop.schemas
+INSTALLS_ICONS= yes
+USE_LDCONFIG= yes
post-patch:
@${FIND} ${WRKSRC} -type f -exec fgrep -l '%%LOCALBASE%%' {} \; |${XARGS} ${REINPLACE_CMD} -e 's,%%LOCALBASE%%,${LOCALBASE},g' -i .bak
diff --git a/net/online-desktop/distinfo b/net/online-desktop/distinfo
index 6387c39c2a7a..5e4189779bdf 100644
--- a/net/online-desktop/distinfo
+++ b/net/online-desktop/distinfo
@@ -1,3 +1,3 @@
-MD5 (online-desktop-0.2.28.tar.bz2) = 79789b90f671008192b8e42ca5514447
-SHA256 (online-desktop-0.2.28.tar.bz2) = 13a22b0c4b3d14fd78f4300fe680c1a52752fd8ee81853846151a4de5fa7e126
-SIZE (online-desktop-0.2.28.tar.bz2) = 382368
+MD5 (online-desktop-0.2.29.tar.bz2) = 98edefd68baae417a5a2d215099398f7
+SHA256 (online-desktop-0.2.29.tar.bz2) = 8499f02d0dc814c5f3519bf5e24c166df65c52633718c6c023158ddfafe49b95
+SIZE (online-desktop-0.2.29.tar.bz2) = 391365
diff --git a/net/online-desktop/pkg-plist b/net/online-desktop/pkg-plist
index 02dafa956c04..04e02d60e1af 100644
--- a/net/online-desktop/pkg-plist
+++ b/net/online-desktop/pkg-plist
@@ -83,21 +83,35 @@ share/icons/hicolor/48x48/apps/google-docs.png
share/icons/hicolor/48x48/apps/google-reader.png
share/icons/hicolor/48x48/apps/picasa.png
share/icons/hicolor/48x48/apps/yahoo-mail.png
-share/online-desktop/autostart/bigboard.desktop
-share/online-desktop/autostart/browser.desktop
-share/online-desktop/autostart/im.desktop
-share/online-desktop/gconf.path
-share/online-desktop/gconf.xml.online-desktop/%gconf-tree.xml
-share/online-desktop/presession/panel-config.py
+%%DATADIR%%/autostart/bigboard.desktop
+%%DATADIR%%/autostart/browser.desktop
+%%DATADIR%%/autostart/im.desktop
+%%DATADIR%%/gconf.path
+%%DATADIR%%/gconf.xml.online-desktop/%gconf-tree.xml
+%%DATADIR%%/presession/panel-config.py
share/online-prefs-sync/online-prefs-sync.synclist
share/xsessions/online-desktop.desktop
-@dirrmtry lib/locale
-@dirrmtry lib/pidgin
-@dirrmtry share/xsessions
+@dirrm share/xsessions
@dirrm share/online-prefs-sync
-@dirrm share/online-desktop/presession
-@dirrm share/online-desktop/gconf.xml.online-desktop
-@dirrm share/online-desktop/autostart
-@dirrm share/online-desktop
+@dirrm %%DATADIR%%/presession
+@dirrm %%DATADIR%%/gconf.xml.online-desktop
+@dirrm %%DATADIR%%/autostart
+@dirrm %%DATADIR%%
+@dirrm share/icons/hicolor/48x48/apps
+@dirrm share/icons/hicolor/48x48
+@dirrm share/icons/hicolor/22x22/apps
+@dirrm share/icons/hicolor/22x22
+@dirrm share/icons/hicolor/16x16/apps
+@dirrm share/icons/hicolor/16x16
+@dirrm share/icons/hicolor
+@dirrm share/icons
+@dirrm share/gnome/autostart
+@dirrm share/gnome
+@dirrm share/dbus-1/services
+@dirrm share/dbus-1
+@dirrm share/applications
@dirrm %%PYTHON_SITELIBDIR%%/pyonlinedesktop
@dirrm %%PYTHON_SITELIBDIR%%/ddm
+@dirrm %%PYTHON_SITELIBDIR%%
+@dirrmtry %%PYTHON_LIBDIR%%
+@dirrmtry lib/pidgin