aboutsummaryrefslogtreecommitdiff
path: root/net/openldap22-server/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/openldap22-server/Makefile')
-rw-r--r--net/openldap22-server/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/net/openldap22-server/Makefile b/net/openldap22-server/Makefile
index fed582a672a0..b1b97ceddecd 100644
--- a/net/openldap22-server/Makefile
+++ b/net/openldap22-server/Makefile
@@ -21,8 +21,19 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ulmo@earthling.net
+.if defined(WITH_DB2)
+BUILD_DEPENDS= ${PREFIX}/lib/libdb2.a:${PORTSDIR}/databases/db/
+CONFIGURE_ENV= CPPFLAGS="-I${PREFIX}/include/db2 -D_THREAD_SAFE" \
+ LDFLAGS=-L${PREFIX}/lib
+.endif
+
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --prefix=${PREFIX} --localstatedir=/var/run
+CONFIGURE_ARGS= --localstatedir=/var/run --enable-shared --enable-dns
+
+# Include tcp-wrapper support
+.if exists(/usr/include/tcpd.h)
+CONFIGURE_ARGS+= --enable-wrappers
+.endif
.include <bsd.port.pre.mk>
.include "${FILESDIR}/manpages"