aboutsummaryrefslogtreecommitdiff
path: root/net/openldap22-server/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/openldap22-server/Makefile')
-rw-r--r--net/openldap22-server/Makefile17
1 files changed, 13 insertions, 4 deletions
diff --git a/net/openldap22-server/Makefile b/net/openldap22-server/Makefile
index fc6130051da4..984b1a7d60fb 100644
--- a/net/openldap22-server/Makefile
+++ b/net/openldap22-server/Makefile
@@ -38,15 +38,24 @@ CONFIGURE_ARGS= --localstatedir=/var/run \
CONFIGURE_ARGS+= --enable-wrappers
.endif
-.if defined(WITH_DB2)
-BUILD_DEPENDS= ${LOCALBASE}/lib/libdb2.a:${PORTSDIR}/databases/db/
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/db2 -D_THREAD_SAFE" \
- LDFLAGS="-L${LOCALBASE}/lib"
+.if defined(WITH_DB2)
+BUILD_DEPENDS= ${LOCALBASE}/lib/libdb2.a:${PORTSDIR}/databases/db
+CPPFLAGS+= -I${LOCALBASE}/include/db2 -D_THREAD_SAFE
CONFIGURE_ARGS+= --enable-ldbm \
--with-ldbm-api=db2
.endif
+.if defined(WITH_SASL)
+LIB_DEPENDS= sasl.8:${PORTSDIR}/security/cyrus-sasl
+CPPFLAGS+= -I${LOCALBASE}/include/sasl
+.endif
+
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+
BINS= bin/ldapadd \
bin/ldapdelete \
bin/ldapmodify \