aboutsummaryrefslogtreecommitdiff
path: root/net/openldap22-server/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/openldap22-server/Makefile')
-rw-r--r--net/openldap22-server/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/net/openldap22-server/Makefile b/net/openldap22-server/Makefile
index 1231a39daa64..c09dfa86cb0b 100644
--- a/net/openldap22-server/Makefile
+++ b/net/openldap22-server/Makefile
@@ -414,8 +414,8 @@ post-install:
${ECHO_CMD} "etc/openldap/schema/$${schema}.schema.default"; \
${ECHO_CMD} "@exec [ -f %B/$${schema}.schema ] || cp %B/%f %B/$${schema}.schema"; \
done >>${TMPPLIST}
- @${ECHO_CMD} "@unexec rmdir %D/etc/openldap/schema 2>/dev/null || true" >>${TMPPLIST}
- @${ECHO_CMD} "@unexec rmdir %D/etc/openldap 2>/dev/null || true" >>${TMPPLIST}
+ @${ECHO_CMD} "@dirrmtry etc/openldap/schema" >>${TMPPLIST}
+ @${ECHO_CMD} "@dirrmtry %D/etc/openldap" >>${TMPPLIST}
@[ "${RC_DIR:S/\/$//}" = "${PREFIX}" ] || ${ECHO_CMD} "@cwd ${RC_DIR}" >>${TMPPLIST}
.for script in slapd slurpd
@${INSTALL_SCRIPT} ${WRKDIR}/${script}.sh ${DESTDIR}${RC_DIR:S/\/$//}/etc/rc.d/${script}${RC_SUFX}