aboutsummaryrefslogtreecommitdiff
path: root/net/openldap24-server
diff options
context:
space:
mode:
Diffstat (limited to 'net/openldap24-server')
-rw-r--r--net/openldap24-server/Makefile13
-rw-r--r--net/openldap24-server/pkg-plist4
2 files changed, 16 insertions, 1 deletions
diff --git a/net/openldap24-server/Makefile b/net/openldap24-server/Makefile
index fed582a672a0..b1b97ceddecd 100644
--- a/net/openldap24-server/Makefile
+++ b/net/openldap24-server/Makefile
@@ -21,8 +21,19 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ulmo@earthling.net
+.if defined(WITH_DB2)
+BUILD_DEPENDS= ${PREFIX}/lib/libdb2.a:${PORTSDIR}/databases/db/
+CONFIGURE_ENV= CPPFLAGS="-I${PREFIX}/include/db2 -D_THREAD_SAFE" \
+ LDFLAGS=-L${PREFIX}/lib
+.endif
+
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --prefix=${PREFIX} --localstatedir=/var/run
+CONFIGURE_ARGS= --localstatedir=/var/run --enable-shared --enable-dns
+
+# Include tcp-wrapper support
+.if exists(/usr/include/tcpd.h)
+CONFIGURE_ARGS+= --enable-wrappers
+.endif
.include <bsd.port.pre.mk>
.include "${FILESDIR}/manpages"
diff --git a/net/openldap24-server/pkg-plist b/net/openldap24-server/pkg-plist
index 66e69eca12ae..d9bc0beec35f 100644
--- a/net/openldap24-server/pkg-plist
+++ b/net/openldap24-server/pkg-plist
@@ -19,8 +19,12 @@ include/ldap_cdefs.h
include/srchpref.h
lib/liblber.a
lib/liblber.la
+lib/liblber.so
+lib/liblber.so.1
lib/libldap.a
lib/libldap.la
+lib/libldap.so
+lib/libldap.so.1
libexec/fax500
libexec/go500
libexec/go500gw