aboutsummaryrefslogtreecommitdiff
path: root/net/openpgm/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/openpgm/Makefile')
-rw-r--r--net/openpgm/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/net/openpgm/Makefile b/net/openpgm/Makefile
index a0a282cd3d8e..ab2721b32ad9 100644
--- a/net/openpgm/Makefile
+++ b/net/openpgm/Makefile
@@ -3,6 +3,7 @@
PORTNAME= openpgm
PORTVERSION= 5.2.122
+PORTREVISION= 1
CATEGORIES= net devel
MASTER_SITES= GOOGLE_CODE
DISTNAME= libpgm-${PORTVERSION}
@@ -13,8 +14,7 @@ COMMENT= Implementation of the PGM reliable multicast protocol
LICENSE= LGPL3
GNU_CONFIGURE= yes
-USE_BZIP2= yes
-USES= pathfix perl5
+USES= pathfix perl5 tar:bzip2 libtool
USE_LDCONFIG= yes
USE_PYTHON= yes
WRKSRC= ${WRKDIR}/${DISTNAME}/openpgm/pgm
@@ -23,7 +23,6 @@ OPTIONS_DEFINE= DOCS EXAMPLES
DOCS_DESC= Install documetation
EXAMPLES_DESC= Install examples
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MEXAMPLES}
@@ -34,14 +33,14 @@ PLIST_SUB+= EXAMPLES="@comment "
post-install:
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_MAN} ${WRKSRC}/../doc/draft-ietf-rmt-bb-pgmcc-03.txt ${DOCSDIR}
- ${INSTALL_MAN} ${WRKSRC}/../doc/rfc3208.txt ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/../doc/draft-ietf-rmt-bb-pgmcc-03.txt ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/../doc/rfc3208.txt ${STAGEDIR}${DOCSDIR}
.endif
.if ${PORT_OPTIONS:MEXAMPLES}
- ${MKDIR} ${EXAMPLESDIR}
- cd ${WRKSRC} && ${COPYTREE_SHARE} examples ${EXAMPLESDIR}
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ cd ${WRKSRC} && ${COPYTREE_SHARE} examples ${STAGEDIR}${EXAMPLESDIR}
.endif
.include <bsd.port.mk>