aboutsummaryrefslogtreecommitdiff
path: root/net/ostinato/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/ostinato/Makefile')
-rw-r--r--net/ostinato/Makefile12
1 files changed, 3 insertions, 9 deletions
diff --git a/net/ostinato/Makefile b/net/ostinato/Makefile
index b73d475fec35..63270c02a1e6 100644
--- a/net/ostinato/Makefile
+++ b/net/ostinato/Makefile
@@ -11,9 +11,10 @@ DISTNAME= ${PORTNAME}-src-${PORTVERSION}${EXTRACTSUFFIX}
MAINTAINER= zeising@FreeBSD.org
COMMENT= Packet crafter/generator and analyzer with friendly GUI
-LIB_DEPENDS= protobuf:${PORTSDIR}/devel/protobuf
+LIB_DEPENDS= libprotobuf.so:${PORTSDIR}/devel/protobuf
-USE_QT4= gui moc_build qmake_build rcc_build uic_build network script \
+USES= qmake
+USE_QT4= gui moc_build rcc_build uic_build network script \
xml
PLIST_FILES= bin/drone \
@@ -21,11 +22,4 @@ PLIST_FILES= bin/drone \
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-HAS_CONFIGURE= yes
-
-NO_STAGE= yes
-do-configure:
- @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
- ${QMAKE} ${QMAKEFLAGS} PREFIX=${PREFIX}
-
.include <bsd.port.mk>