aboutsummaryrefslogtreecommitdiff
path: root/net/p5-BBS-UserInfo-Maple3itoc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/p5-BBS-UserInfo-Maple3itoc/Makefile')
-rw-r--r--net/p5-BBS-UserInfo-Maple3itoc/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/net/p5-BBS-UserInfo-Maple3itoc/Makefile b/net/p5-BBS-UserInfo-Maple3itoc/Makefile
new file mode 100644
index 000000000000..d27f129c6c19
--- /dev/null
+++ b/net/p5-BBS-UserInfo-Maple3itoc/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-BBS-UserInfo-Maple3itoc
+# Date created: 2006-08-20
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= BBS-UserInfo-Maple3itoc
+PORTVERSION= 0.01
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/G/GS/GSLIN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Get user information of Maple3itoc-style BBS
+
+RUN_DEPENDS= ${SITE_PERL}/Expect.pm:${PORTSDIR}/lang/p5-Expect
+
+PERL_CONFIGURE= yes
+
+MAN3= BBS::UserInfo::Maple3itoc.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800 # Inherited from lang/p5-Expect
+IGNORE= requires perl 5.8.0 or newer. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>