aboutsummaryrefslogtreecommitdiff
path: root/net/p5-File-RsyncP
diff options
context:
space:
mode:
Diffstat (limited to 'net/p5-File-RsyncP')
-rw-r--r--net/p5-File-RsyncP/Makefile15
-rw-r--r--net/p5-File-RsyncP/distinfo3
-rw-r--r--net/p5-File-RsyncP/files/patch-Digest.xs12
-rw-r--r--net/p5-File-RsyncP/files/patch-FileIO.pm20
-rw-r--r--net/p5-File-RsyncP/files/patch-FileList.pm40
-rw-r--r--net/p5-File-RsyncP/files/patch-FileList.xs45
-rw-r--r--net/p5-File-RsyncP/files/patch-RsyncP.pm38
-rw-r--r--net/p5-File-RsyncP/files/patch-md4.h16
8 files changed, 15 insertions, 174 deletions
diff --git a/net/p5-File-RsyncP/Makefile b/net/p5-File-RsyncP/Makefile
index c9ef5783dfa5..b1f3e4854e19 100644
--- a/net/p5-File-RsyncP/Makefile
+++ b/net/p5-File-RsyncP/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= File-RsyncP
-PORTVERSION= 0.44
+PORTVERSION= 0.46
CATEGORIES= net perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= File
@@ -25,4 +25,15 @@ MAN3= File::RsyncP.3 \
post-patch:
@${FIND} ${WRKSRC} -name \*.orig -delete
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} <= 500503
+# make PREFIX-clean under perl 5.005_03
+post-configure:
+ ${PERL} -pi -e 's,/usr/local/,\$$(PREFIX)/,g' \
+ ${WRKSRC}/Makefile \
+ ${WRKSRC}/Digest/Makefile \
+ ${WRKSRC}/FileList/Makefile
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/p5-File-RsyncP/distinfo b/net/p5-File-RsyncP/distinfo
index 351cfbfed603..28723b2bc978 100644
--- a/net/p5-File-RsyncP/distinfo
+++ b/net/p5-File-RsyncP/distinfo
@@ -1 +1,2 @@
-MD5 (File-RsyncP-0.44.tar.gz) = 1c238af568362c8ed6da7d2691fda1bb
+MD5 (File-RsyncP-0.46.tar.gz) = b26561cc6fb32c4e73595ee941207a8c
+SIZE (File-RsyncP-0.46.tar.gz) = 57356
diff --git a/net/p5-File-RsyncP/files/patch-Digest.xs b/net/p5-File-RsyncP/files/patch-Digest.xs
deleted file mode 100644
index fd41b322ebf7..000000000000
--- a/net/p5-File-RsyncP/files/patch-Digest.xs
+++ /dev/null
@@ -1,12 +0,0 @@
---- Digest/Digest.xs.orig Sat Jan 10 16:27:37 2004
-+++ Digest/Digest.xs Sat Jan 10 16:28:38 2004
-@@ -169,8 +169,7 @@
- }
-
- SV *
--blockDigestUpdate(context, dataV, blockSize=700, blockLastLen=0, \
-- md4DigestLen=16, seed=0)
-+blockDigestUpdate(context, dataV, blockSize=700, blockLastLen=0, md4DigestLen=16, seed=0)
- PREINIT:
- STRLEN len;
- INPUT:
diff --git a/net/p5-File-RsyncP/files/patch-FileIO.pm b/net/p5-File-RsyncP/files/patch-FileIO.pm
deleted file mode 100644
index fe77c84a211a..000000000000
--- a/net/p5-File-RsyncP/files/patch-FileIO.pm
+++ /dev/null
@@ -1,20 +0,0 @@
---- lib/File/RsyncP/FileIO.pm.orig Thu Jul 24 04:33:37 2003
-+++ lib/File/RsyncP/FileIO.pm Mon Jan 12 10:57:29 2004
-@@ -44,7 +44,7 @@
- use File::Find;
- use Data::Dumper;
-
--our $VERSION = '0.44';
-+use vars qw($VERSION); $VERSION = '0.44';
-
- use constant S_IFMT => 0170000; # type of file
- use constant S_IFDIR => 0040000; # directory
-@@ -664,7 +664,7 @@
-
- foreach my $str ( @logStr ) {
- next if ( $str eq "" );
-- $fio->{logHandler}($str);
-+ $fio->{logHandler}->($str);
- }
- }
-
diff --git a/net/p5-File-RsyncP/files/patch-FileList.pm b/net/p5-File-RsyncP/files/patch-FileList.pm
deleted file mode 100644
index 42a6155a9703..000000000000
--- a/net/p5-File-RsyncP/files/patch-FileList.pm
+++ /dev/null
@@ -1,40 +0,0 @@
---- FileList/FileList.pm.orig Mon Jan 12 10:52:48 2004
-+++ FileList/FileList.pm Mon Jan 12 10:53:50 2004
-@@ -39,14 +39,13 @@
-
- package File::RsyncP::FileList;
-
--use 5.006;
- use strict;
--use warnings;
-
- require Exporter;
- require DynaLoader;
-
--our @ISA = qw(Exporter AutoLoader DynaLoader);
-+use vars qw(@ISA %EXPORT_TAGS @EXPORT_OK @EXPORT $VERSION);
-+@ISA = qw(Exporter AutoLoader DynaLoader);
-
- # Items to export into callers namespace by default. Note: do not export
- # names by default without a very good reason. Use EXPORT_OK instead.
-@@ -55,16 +54,16 @@
- # This allows declaration use File::RsyncP::FileList ':all';
- # If you do not need this, moving things directly into @EXPORT or @EXPORT_OK
- # will save memory.
--our %EXPORT_TAGS = ( 'all' => [ qw(
-+%EXPORT_TAGS = ( 'all' => [ qw(
-
- ) ] );
-
--our @EXPORT_OK = ( @{ $EXPORT_TAGS{'all'} } );
-+@EXPORT_OK = ( @{ $EXPORT_TAGS{'all'} } );
-
--our @EXPORT = qw(
-+@EXPORT = qw(
-
- );
--our $VERSION = '0.44';
-+$VERSION = '0.44';
-
- bootstrap File::RsyncP::FileList $VERSION;
-
diff --git a/net/p5-File-RsyncP/files/patch-FileList.xs b/net/p5-File-RsyncP/files/patch-FileList.xs
deleted file mode 100644
index 930c1cb1d020..000000000000
--- a/net/p5-File-RsyncP/files/patch-FileList.xs
+++ /dev/null
@@ -1,45 +0,0 @@
---- FileList/FileList.xs.orig Thu Jul 24 04:33:37 2003
-+++ FileList/FileList.xs Mon Jan 12 10:27:51 2004
-@@ -93,8 +93,9 @@
- PROTOTYPES: DISABLE
-
- File::RsyncP::FileList
--new(packname = "File::RsyncP::FileList", SV* opts = NULL)
-+new(packname = "File::RsyncP::FileList", opts = NULL)
- char *packname
-+ SV* opts
- CODE:
- {
- RETVAL = flist_new();
-@@ -187,14 +188,14 @@
- if ( file->sum )
- hv_store(rh, "sum", 3, newSVpv(file->sum, 0), 0);
- hv_store(rh, "name", 4, newSVpv(f_name(file), 0), 0);
-- hv_store(rh, "uid", 3, newSVuv(file->uid), 0);
-- hv_store(rh, "gid", 3, newSVuv(file->gid), 0);
-- hv_store(rh, "mode", 4, newSVuv(file->mode), 0);
-- hv_store(rh, "mtime", 5, newSVuv(file->modtime), 0);
-+ hv_store(rh, "uid", 3, newSViv(file->uid), 0);
-+ hv_store(rh, "gid", 3, newSViv(file->gid), 0);
-+ hv_store(rh, "mode", 4, newSViv(file->mode), 0);
-+ hv_store(rh, "mtime", 5, newSViv(file->modtime), 0);
- hv_store(rh, "size", 4, newSVnv(file->length), 0);
- hv_store(rh, "dev", 3, newSVnv(file->dev), 0);
- hv_store(rh, "inode", 5, newSVnv(file->inode), 0);
-- hv_store(rh, "rdev", 4, newSVuv(file->rdev), 0);
-+ hv_store(rh, "rdev", 4, newSViv(file->rdev), 0);
- RETVAL = newRV((SV*)rh);
- }
- OUTPUT:
-@@ -210,9 +211,10 @@
- }
-
- void
--encode(flist, SV* data)
-+encode(flist, data)
- INPUT:
- File::RsyncP::FileList flist
-+ SV* data
- CODE:
- {
- struct file_struct file, *fileCopy;
diff --git a/net/p5-File-RsyncP/files/patch-RsyncP.pm b/net/p5-File-RsyncP/files/patch-RsyncP.pm
deleted file mode 100644
index aa3019dc71da..000000000000
--- a/net/p5-File-RsyncP/files/patch-RsyncP.pm
+++ /dev/null
@@ -1,38 +0,0 @@
---- lib/File/RsyncP.pm.orig Thu Jul 24 04:33:37 2003
-+++ lib/File/RsyncP.pm Mon Jan 12 10:31:36 2004
-@@ -48,7 +48,7 @@
- use Getopt::Long;
- use Data::Dumper;
-
--our $VERSION = '0.44';
-+use vars qw($VERSION); $VERSION = '0.44';
-
- use constant S_IFMT => 0170000; # type of file
- use constant S_IFDIR => 0040000; # directory
-@@ -267,7 +267,7 @@
- close(RSYNC);
- $rs->{fh} = *FH;
- $rs->{rsyncPID} = $pid;
-- $rs->{pidHandler}($rs->{rsyncPID}, $rs->{childPID})
-+ $rs->{pidHandler}->($rs->{rsyncPID}, $rs->{childPID})
- if ( defined($rs->{pidHandler}) );
- #
- # Write our version and get the remote version
-@@ -391,7 +391,7 @@
- $rs->{childFh} = *RH;
- $rs->{childPID} = $pid;
- $rs->log("Child PID is $pid") if ( $rs->{logLevel} >= 2 );
-- $rs->{pidHandler}($rs->{rsyncPID}, $rs->{childPID})
-+ $rs->{pidHandler}->($rs->{rsyncPID}, $rs->{childPID})
- if ( defined($rs->{pidHandler}) );
- setsockopt($rs->{fh}, SOL_SOCKET, SO_SNDBUF, 8 * 65536);
- setsockopt($rs->{childFh}, SOL_SOCKET, SO_RCVBUF, 8 * 65536);
-@@ -1088,7 +1088,7 @@
-
- foreach my $str ( @logStr ) {
- next if ( $str eq "" );
-- $rs->{logHandler}($str);
-+ $rs->{logHandler}->($str);
- }
- }
-
diff --git a/net/p5-File-RsyncP/files/patch-md4.h b/net/p5-File-RsyncP/files/patch-md4.h
deleted file mode 100644
index f1acdb6d02e7..000000000000
--- a/net/p5-File-RsyncP/files/patch-md4.h
+++ /dev/null
@@ -1,16 +0,0 @@
---- Digest/md4.h.orig Mon Jan 12 10:37:04 2004
-+++ Digest/md4.h Mon Jan 12 10:44:59 2004
-@@ -38,6 +38,13 @@
- unsigned char rsyncBug;
- } MD4_CTX;
-
-+#define MD4Init myMD4Init
-+#define MD4Update myMD4Update
-+#define MD4Final myMD4Final
-+#define MD4Encode myMD4Encode
-+#define MD4FinalRsync myMD4FinalRsync
-+#define MD4Decode myMD4Decode
-+
- void MD4Init PROTO_LIST ((MD4_CTX *));
- void MD4Update PROTO_LIST
- ((MD4_CTX *, unsigned char *, unsigned int));