aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-Amazon-Thumbnail/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/p5-Net-Amazon-Thumbnail/Makefile')
-rw-r--r--net/p5-Net-Amazon-Thumbnail/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/net/p5-Net-Amazon-Thumbnail/Makefile b/net/p5-Net-Amazon-Thumbnail/Makefile
new file mode 100644
index 000000000000..2b7633caeee5
--- /dev/null
+++ b/net/p5-Net-Amazon-Thumbnail/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: p5-Net-Amazon-Thumbnail
+# Date created: 2008-03-20
+# Whom: Greg Larkin <glarkin@sourcehosting.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Amazon-Thumbnail
+PORTVERSION= 0.06
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= glarkin@sourcehosting.net
+COMMENT= Perl interface to Amazon Alexa Site Thumbnail web service
+
+RUN_DEPENDS= ${SITE_PERL}/Class/Accessor.pm:${PORTSDIR}/devel/p5-Class-Accessor \
+ ${SITE_PERL}/${PERL_ARCH}/File/Spec.pm:${PORTSDIR}/devel/p5-PathTools \
+ ${SITE_PERL}/Digest/HMAC_SHA1.pm:${PORTSDIR}/security/p5-Digest-HMAC \
+ ${SITE_PERL}/URI/QueryParam.pm:${PORTSDIR}/net/p5-URI \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/Test/Exception.pm:${PORTSDIR}/devel/p5-Test-Exception \
+ ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ ${SITE_PERL}/XML/XPath.pm:${PORTSDIR}/textproc/p5-XML-XPath
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Net::Amazon::Thumbnail.3
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>