aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-Ident
diff options
context:
space:
mode:
Diffstat (limited to 'net/p5-Net-Ident')
-rw-r--r--net/p5-Net-Ident/Makefile23
-rw-r--r--net/p5-Net-Ident/distinfo1
-rw-r--r--net/p5-Net-Ident/pkg-descr10
-rw-r--r--net/p5-Net-Ident/pkg-plist5
4 files changed, 39 insertions, 0 deletions
diff --git a/net/p5-Net-Ident/Makefile b/net/p5-Net-Ident/Makefile
new file mode 100644
index 000000000000..da6174d0a6ab
--- /dev/null
+++ b/net/p5-Net-Ident/Makefile
@@ -0,0 +1,23 @@
+# ex:ts=8
+# Ports collection makefile for: p5-Net-Ident
+# Date created: Oct 30, 2003
+# Whom: kai
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Ident
+PORTVERSION= 1.20
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kai@xs4all.nl
+COMMENT= Lookup the username on the remote end of a TCP/IP connection
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::Ident.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Ident/distinfo b/net/p5-Net-Ident/distinfo
new file mode 100644
index 000000000000..c20f03479840
--- /dev/null
+++ b/net/p5-Net-Ident/distinfo
@@ -0,0 +1 @@
+MD5 (Net-Ident-1.20.tar.gz) = 70f265f46548675be01977d3c9eed570
diff --git a/net/p5-Net-Ident/pkg-descr b/net/p5-Net-Ident/pkg-descr
new file mode 100644
index 000000000000..ac7254f1bac8
--- /dev/null
+++ b/net/p5-Net-Ident/pkg-descr
@@ -0,0 +1,10 @@
+Net::Ident is a module that looks up the username on the remote side of a
+TCP/IP connection through the ident (auth/tap) protocol described in
+RFC1413 (which supersedes RFC931). Note that this requires the remote
+site to run a daemon (often called identd) to provide the requested
+information, so it is not always available for all TCP/IP connections.
+
+WWW: http://search.cpan.org/dist/Net-Ident
+
+ Kai Storbeck
+ kai@xs4all.nl
diff --git a/net/p5-Net-Ident/pkg-plist b/net/p5-Net-Ident/pkg-plist
new file mode 100644
index 000000000000..c197775b6b08
--- /dev/null
+++ b/net/p5-Net-Ident/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Net/Ident.pm
+%%SITE_PERL%%/mach/auto/Net/Ident/.packlist
+@dirrm %%SITE_PERL%%/mach/auto/Net/Ident
+@unexec rmdir %D/%%SITE_PERL%%/mach/auto/Net 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Net 2>/dev/null || true