aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-OAuth
diff options
context:
space:
mode:
Diffstat (limited to 'net/p5-Net-OAuth')
-rw-r--r--net/p5-Net-OAuth/Makefile14
-rw-r--r--net/p5-Net-OAuth/distinfo6
-rw-r--r--net/p5-Net-OAuth/pkg-plist9
3 files changed, 23 insertions, 6 deletions
diff --git a/net/p5-Net-OAuth/Makefile b/net/p5-Net-OAuth/Makefile
index 04ae8adeacb5..3354a3eb5c6b 100644
--- a/net/p5-Net-OAuth/Makefile
+++ b/net/p5-Net-OAuth/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= Net-OAuth
-PORTVERSION= 0.06
+PORTVERSION= 0.08
CATEGORIES= net perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -24,12 +24,20 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_MODBUILD= yes
-MAN3= Net::OAuth::AccessTokenRequest.3 \
+MAN3= Net::OAuth.3 \
+ Net::OAuth::AccessTokenRequest.3 \
+ Net::OAuth::AccessTokenResponse.3 \
+ Net::OAuth::Message.3 \
Net::OAuth::ProtectedResourceRequest.3 \
Net::OAuth::Request.3 \
Net::OAuth::RequestTokenRequest.3 \
+ Net::OAuth::RequestTokenResponse.3 \
+ Net::OAuth::Response.3 \
Net::OAuth::SignatureMethod::HMAC_SHA1.3 \
Net::OAuth::SignatureMethod::PLAINTEXT.3 \
- Net::OAuth::SignatureMethod::RSA_SHA1.3
+ Net::OAuth::SignatureMethod::RSA_SHA1.3 \
+ Net::OAuth::UserAuthRequest.3 \
+ Net::OAuth::UserAuthResponse.3 \
+
.include <bsd.port.mk>
diff --git a/net/p5-Net-OAuth/distinfo b/net/p5-Net-OAuth/distinfo
index 1b6fdcc12623..85efab386e9e 100644
--- a/net/p5-Net-OAuth/distinfo
+++ b/net/p5-Net-OAuth/distinfo
@@ -1,3 +1,3 @@
-MD5 (Net-OAuth-0.06.tar.gz) = 73321c00df15885ca17d8ef82864be93
-SHA256 (Net-OAuth-0.06.tar.gz) = e98e92bf9fa95e3ffbe32811a740ea34f65bdf82fb6cd2d39027c0233405617a
-SIZE (Net-OAuth-0.06.tar.gz) = 7700
+MD5 (Net-OAuth-0.08.tar.gz) = 9cf23f7f5faa98baeb997b8b9ee9334d
+SHA256 (Net-OAuth-0.08.tar.gz) = cc1da3dbecd177beaa73e1a0b3985418c4e2380b3d6c82c45764e6034969a399
+SIZE (Net-OAuth-0.08.tar.gz) = 12235
diff --git a/net/p5-Net-OAuth/pkg-plist b/net/p5-Net-OAuth/pkg-plist
index 92952ed4a158..17dd2ae45589 100644
--- a/net/p5-Net-OAuth/pkg-plist
+++ b/net/p5-Net-OAuth/pkg-plist
@@ -1,10 +1,19 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/Net/OAuth
+%%SITE_PERL%%/Net/OAuth.pm
%%SITE_PERL%%/Net/OAuth/AccessTokenRequest.pm
+%%SITE_PERL%%/Net/OAuth/AccessTokenResponse.pm
+%%SITE_PERL%%/Net/OAuth/Message.pm
%%SITE_PERL%%/Net/OAuth/ProtectedResourceRequest.pm
%%SITE_PERL%%/Net/OAuth/Request.pm
%%SITE_PERL%%/Net/OAuth/RequestTokenRequest.pm
+%%SITE_PERL%%/Net/OAuth/RequestTokenResponse.pm
+%%SITE_PERL%%/Net/OAuth/Response.pm
%%SITE_PERL%%/Net/OAuth/SignatureMethod/HMAC_SHA1.pm
%%SITE_PERL%%/Net/OAuth/SignatureMethod/PLAINTEXT.pm
%%SITE_PERL%%/Net/OAuth/SignatureMethod/RSA_SHA1.pm
+%%SITE_PERL%%/Net/OAuth/UserAuthRequest.pm
+%%SITE_PERL%%/Net/OAuth/UserAuthResponse.pm
@dirrm %%SITE_PERL%%/Net/OAuth/SignatureMethod
@dirrm %%SITE_PERL%%/Net/OAuth
@dirrmtry %%SITE_PERL%%/Net