aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-Pcap/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/p5-Net-Pcap/Makefile')
-rw-r--r--net/p5-Net-Pcap/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/net/p5-Net-Pcap/Makefile b/net/p5-Net-Pcap/Makefile
index ed4f82bdd569..73244b6b611d 100644
--- a/net/p5-Net-Pcap/Makefile
+++ b/net/p5-Net-Pcap/Makefile
@@ -18,7 +18,14 @@ COMMENT= Interface to pcap(3) LBL packet capture library
BUILD_DEPENDS+= ${LOCALBASE}/lib/libpcap.a:${PORTSDIR}/net/libpcap
PERL_CONFIGURE= yes
+CONFIGURE_ARGS= INC="-I${LOCALBASE}/include" LIBS="-I${LOCALBASE}/lib -lpcap"
MAN3= Net::Pcap.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= Perl 5.6 or newer required. Install lang/perl5.8 (or lang/perl5) and try again.
+.endif
+
+.include <bsd.port.post.mk>