aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-SNPP/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/p5-Net-SNPP/Makefile')
-rw-r--r--net/p5-Net-SNPP/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/net/p5-Net-SNPP/Makefile b/net/p5-Net-SNPP/Makefile
index f51491873445..36f5d8b819ca 100644
--- a/net/p5-Net-SNPP/Makefile
+++ b/net/p5-Net-SNPP/Makefile
@@ -15,12 +15,15 @@ PKGNAMEPREFIX= p5-
MAINTAINER= erwin@lansing.dk
COMMENT= Net::SNPP - Perl Simple Network Pager Protocol Client
-BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Net/Cmd.pm:${PORTSDIR}/net/p5-Net
-RUN_DEPENDS= ${BUILD_DEPENDS}
-
PERL_CONFIGURE= yes
-MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Net::SNPP.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Net/Cmd.pm:${PORTSDIR}/net/p5-Net
+RUN_DEPENDS= ${BUILD_DEPENDS}
+.endif
+
+.include <bsd.port.post.mk>