aboutsummaryrefslogtreecommitdiff
path: root/net/p5-ldap2pf/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/p5-ldap2pf/Makefile')
-rw-r--r--net/p5-ldap2pf/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/net/p5-ldap2pf/Makefile b/net/p5-ldap2pf/Makefile
new file mode 100644
index 000000000000..a042dba41535
--- /dev/null
+++ b/net/p5-ldap2pf/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= ldap2pf
+PORTVERSION= 20151101
+CATEGORIES= net
+MASTER_SITES= GH
+
+MAINTAINER= des@FreeBSD.org
+COMMENT= Create and update PF tables from LDAP groups
+
+RUN_DEPENDS= p5-Authen-SASL>=0:${PORTSDIR}/security/p5-Authen-SASL \
+ p5-IO-Socket-INET6>=0:${PORTSDIR}/net/p5-IO-Socket-INET6 \
+ p5-Net-DNS>=0:${PORTSDIR}/dns/p5-Net-DNS \
+ p5-Regexp-Common>=0:${PORTSDIR}/textproc/p5-Regexp-Common \
+ p5-Try-Tiny>=0:${PORTSDIR}/lang/p5-Try-Tiny \
+ p5-perl-ldap>=0:${PORTSDIR}/net/p5-perl-ldap
+
+USE_GITHUB= yes
+GH_ACCOUNT= dag-erling
+
+USES= perl5
+USE_PERL5= configure run
+
+PLIST_FILES= bin/ldap2pf
+
+.include <bsd.port.mk>